aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/apache20/Makefile2
-rw-r--r--www/apache22/Makefile2
-rw-r--r--www/c-icap/Makefile1
-rw-r--r--www/cadaver/Makefile1
-rw-r--r--www/cgicc/Makefile1
-rw-r--r--www/dpsearch/Makefile1
-rw-r--r--www/ffproxy/Makefile1
-rw-r--r--www/havp/Makefile1
-rw-r--r--www/hiawatha/Makefile1
-rw-r--r--www/hydra/Makefile1
-rw-r--r--www/lighttpd/Makefile1
-rw-r--r--www/lynx-current/Makefile1
-rw-r--r--www/lynx/Makefile1
-rw-r--r--www/man2web/Makefile1
-rw-r--r--www/middleman/Makefile1
-rw-r--r--www/mnogosearch/Makefile1
-rw-r--r--www/mnogosearch31/Makefile1
-rw-r--r--www/mod_auth_form/Makefile1
-rw-r--r--www/neonpp/Makefile1
-rw-r--r--www/netrik/Makefile1
-rw-r--r--www/openvrml/Makefile1
-rw-r--r--www/sams/Makefile1
-rw-r--r--www/sarg/Makefile1
-rw-r--r--www/tidy-devel/Makefile1
-rw-r--r--www/varnish/Makefile1
-rw-r--r--www/varnish2/Makefile1
-rw-r--r--www/wml/Makefile1
-rw-r--r--www/xshttpd-devel/Makefile1
-rw-r--r--www/xshttpd/Makefile1
29 files changed, 2 insertions, 29 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index af596b58815e..83e70ec0cc52 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -157,7 +157,7 @@ CFLAGS+= -DFREEBSD_THREAD_HACK
. endif
.endif
-CONFIGURE_ARGS+= --with-mpm=${WITH_MPM:L} ${CONFIGURE_TARGET}
+CONFIGURE_ARGS+= --with-mpm=${WITH_MPM:L}
show-options:
@${SED} -ne 's/^##//p' ${APACHEDIR}/Makefile.doc
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 1ab9d03d7cd5..60c14d8bea0b 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -164,7 +164,7 @@ CONFIGURE_ARGS+= --enable-nonportable-atomics
. endif
.endif
-CONFIGURE_ARGS+= --with-mpm=${WITH_MPM:L} ${CONFIGURE_TARGET}
+CONFIGURE_ARGS+= --with-mpm=${WITH_MPM:L}
pre-everything::
@${ECHO_MSG} ""
diff --git a/www/c-icap/Makefile b/www/c-icap/Makefile
index cb801ea35557..d94cce93dd67 100644
--- a/www/c-icap/Makefile
+++ b/www/c-icap/Makefile
@@ -22,7 +22,6 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_RC_SUBR= c_icap
USE_AUTOTOOLS= libtool:15
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
LDCONFIG_DIRS= %%PREFIX%%/lib %%PREFIX%%/lib/c_icap
SUB_FILES= pkg-install pkg-deinstall
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index f10493103bdd..b4a0b5a8b878 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -17,7 +17,6 @@ COMMENT= Commandline client for DAV
LIB_DEPENDS= neon.28:${PORTSDIR}/www/neon28
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-netrc
ALL_TARGET= cadaver
diff --git a/www/cgicc/Makefile b/www/cgicc/Makefile
index 8b4879253e62..6775c33273ae 100644
--- a/www/cgicc/Makefile
+++ b/www/cgicc/Makefile
@@ -18,7 +18,6 @@ COMMENT= A C++ class library for writing CGI applications
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAKE_ARGS= NOPORTDOCS=${NOPORTDOCS}
USE_LDCONFIG= yes
diff --git a/www/dpsearch/Makefile b/www/dpsearch/Makefile
index 901370a0e623..1064eb82f891 100644
--- a/www/dpsearch/Makefile
+++ b/www/dpsearch/Makefile
@@ -19,7 +19,6 @@ USE_GMAKE= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
DOCSDIR= ${PREFIX}/share/doc/dataparksearch
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc/dpsearch \
--localstatedir=/var/dpsearch \
--enable-mp3 \
diff --git a/www/ffproxy/Makefile b/www/ffproxy/Makefile
index 3ae3bf0c21a5..04f3a8a949ce 100644
--- a/www/ffproxy/Makefile
+++ b/www/ffproxy/Makefile
@@ -14,7 +14,6 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Filtering HTTP proxy server
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/www/havp/Makefile b/www/havp/Makefile
index 57889ae39519..c52c3fbccdc0 100644
--- a/www/havp/Makefile
+++ b/www/havp/Makefile
@@ -20,7 +20,6 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5_BUILD= yes
USE_RC_SUBR= havp
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --disable-locking
LOG_DIR= /var/log/havp
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
index 7d1d27b3280b..5faab18d27eb 100644
--- a/www/hiawatha/Makefile
+++ b/www/hiawatha/Makefile
@@ -24,7 +24,6 @@ SUB_FILES= pkg-message
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var webrootdir=${WWWDIR}
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
OPTIONS= COMMAND "Enable the Hiawatha CommandChannel" Off \
CACHE "Internal file caching support" On \
diff --git a/www/hydra/Makefile b/www/hydra/Makefile
index 812e839083ab..18fb0b1529e8 100644
--- a/www/hydra/Makefile
+++ b/www/hydra/Makefile
@@ -22,7 +22,6 @@ USE_RC_SUBR= hydra.sh
NO_LATEST_LINK= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CPPFLAGS= -I${LOCALBASE}/include
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 8ca22717e76b..ecb52076392f 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -24,7 +24,6 @@ USE_GNOME= lthack
USE_RC_SUBR= lighttpd.sh
CONFIGURE_ARGS= --libdir=${PREFIX}/lib/lighttpd
CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/www/lynx-current/Makefile b/www/lynx-current/Makefile
index 079b9c447fc9..8b81faa2dec4 100644
--- a/www/lynx-current/Makefile
+++ b/www/lynx-current/Makefile
@@ -24,7 +24,6 @@ USE_BZIP2= yes
USE_ICONV= yes
NO_LATEST_LINK= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-zlib --libdir="${L_LIB}" \
--enable-nsl-fork --enable-nls --with-bzlib \
--enable-nested-tables --enable-default-colors \
diff --git a/www/lynx/Makefile b/www/lynx/Makefile
index 0c586afa7e84..43ddaae39a71 100644
--- a/www/lynx/Makefile
+++ b/www/lynx/Makefile
@@ -23,7 +23,6 @@ USE_BZIP2= yes
USE_OPENSSL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}2-8-6
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+=--with-zlib --libdir="${L_LIB}" \
--enable-nsl-fork --enable-persistent-cookies \
--enable-nested-tables --enable-gzip-help \
diff --git a/www/man2web/Makefile b/www/man2web/Makefile
index b8a39dee436f..370f9cf22c71 100644
--- a/www/man2web/Makefile
+++ b/www/man2web/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= naddy@FreeBSD.org
COMMENT= Convert man pages to HTML
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --bindir="${PREFIX}/${CGIDIR}" \
--sysconfdir="${PREFIX}/etc" \
--with-manpath=/usr/share/man:${LOCALBASE}/man \
diff --git a/www/middleman/Makefile b/www/middleman/Makefile
index 5013d7cda030..ad8896ab76d8 100644
--- a/www/middleman/Makefile
+++ b/www/middleman/Makefile
@@ -17,7 +17,6 @@ COMMENT= A robust proxy server
WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
diff --git a/www/mnogosearch/Makefile b/www/mnogosearch/Makefile
index e9aca991fdb4..f19cfceccbd5 100644
--- a/www/mnogosearch/Makefile
+++ b/www/mnogosearch/Makefile
@@ -20,7 +20,6 @@ USE_LDCONFIG= yes
USE_GNOME= lthack
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+=--enable-shared \
--sysconfdir=${PREFIX}/etc/mnogosearch \
--localstatedir=/var/mnogosearch \
diff --git a/www/mnogosearch31/Makefile b/www/mnogosearch31/Makefile
index 69eae67940c2..3badf0135b00 100644
--- a/www/mnogosearch31/Makefile
+++ b/www/mnogosearch31/Makefile
@@ -24,7 +24,6 @@ USE_LDCONFIG= yes
USE_GMAKE= yes
APACHE_COMPAT= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+=--enable-phrase \
--enable-shared \
--sysconfdir=${PREFIX}/etc/mnogosearch \
diff --git a/www/mod_auth_form/Makefile b/www/mod_auth_form/Makefile
index 1d593087236e..314df0f35b42 100644
--- a/www/mod_auth_form/Makefile
+++ b/www/mod_auth_form/Makefile
@@ -20,7 +20,6 @@ USE_MYSQL= YES
USE_APACHE= 2.0+
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= MYSQL_PREFIX="${LOCALBASE}" APACHE2_PREFIX="${LOCALBASE}" \
APACHE2_INCLUDE="${LOCALBASE}/include/apache${APACHE_VERSION}" \
APR1_INCLUDE="${LOCALBASE}/include/apache2"
diff --git a/www/neonpp/Makefile b/www/neonpp/Makefile
index 55e0d061113f..464ae61b45aa 100644
--- a/www/neonpp/Makefile
+++ b/www/neonpp/Makefile
@@ -22,6 +22,5 @@ LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-pkgconfig-dir=${PREFIX}/libdata/pkgconfig
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/www/netrik/Makefile b/www/netrik/Makefile
index 2e2ecb39a7c3..1d4180d40dcf 100644
--- a/www/netrik/Makefile
+++ b/www/netrik/Makefile
@@ -21,7 +21,6 @@ RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PLIST_FILES= bin/netrik
diff --git a/www/openvrml/Makefile b/www/openvrml/Makefile
index 7ea83593cf01..dafe6038c952 100644
--- a/www/openvrml/Makefile
+++ b/www/openvrml/Makefile
@@ -34,7 +34,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${JAVA_HOME}/include -I${JAVA_
LDFLAGS="-L${LOCALBASE}/lib -L${JAVA_HOME}/jre/lib/${ARCH}/client ${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}" \
LIBS="-lm"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_LDCONFIG= yes
USE_GECKO= firefox seamonkey
diff --git a/www/sams/Makefile b/www/sams/Makefile
index 542620dc79e5..b8a9a6af2a08 100644
--- a/www/sams/Makefile
+++ b/www/sams/Makefile
@@ -35,7 +35,6 @@ OPTIONSFILE?= ${PORT_DBDIR}/${PORTNAME}/options
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS=--with-configfile=${LOCALBASE}/etc/sams.conf \
--with-rcd-locations=${LOCALBASE}/etc/rc.d/ \
--with-httpd-locations=${DOCUMENT_ROOT}
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index 03bd301e57c9..82fefc21c103 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -26,7 +26,6 @@ CONFIGURE_ARGS= --enable-bindir="${PREFIX}/bin" \
--enable-sysconfdir="${PREFIX}/etc/${PORTNAME}" \
--enable-htmldir="${PREFIX}/www/${PORTNAME}" \
--enable-mandir="${MAN1PREFIX}/man/man1"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= sarg.1
diff --git a/www/tidy-devel/Makefile b/www/tidy-devel/Makefile
index a4af040c575a..3844c5c6b321 100644
--- a/www/tidy-devel/Makefile
+++ b/www/tidy-devel/Makefile
@@ -32,7 +32,6 @@ CONFLICTS= tidy-20000804* tidy-lib-[0-9]*
.else
USE_AUTOTOOLS= automake:15 autoconf:262 libtool:15
AUTOMAKE_ARGS+= -a -c --foreign
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_LDCONFIG= yes
PLIST_SUB= SHLIB="" NSHLIB="@comment "
CONFLICTS= tidy-20000804* tidy-devel-[0-9]*
diff --git a/www/varnish/Makefile b/www/varnish/Makefile
index 56d3334549b8..804c1260d736 100644
--- a/www/varnish/Makefile
+++ b/www/varnish/Makefile
@@ -14,7 +14,6 @@ MAINTAINER= des@FreeBSD.org
COMMENT= The Varnish high-performance HTTP accelerator
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=${PREFIX}
USE_LDCONFIG= yes
diff --git a/www/varnish2/Makefile b/www/varnish2/Makefile
index 56d3334549b8..804c1260d736 100644
--- a/www/varnish2/Makefile
+++ b/www/varnish2/Makefile
@@ -14,7 +14,6 @@ MAINTAINER= des@FreeBSD.org
COMMENT= The Varnish high-performance HTTP accelerator
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=${PREFIX}
USE_LDCONFIG= yes
diff --git a/www/wml/Makefile b/www/wml/Makefile
index 0712896c6eaf..fa527ea8b24c 100644
--- a/www/wml/Makefile
+++ b/www/wml/Makefile
@@ -23,7 +23,6 @@ CONFIGURE_ARGS= --with-perl=${PERL5} --with-catdir=man \
--prefix=${PREFIX}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" \
PERL_ARCH="${PERL_ARCH}"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
GNU_CONFIGURE= yes
LIBTOOLFILES= wml_backend/p2_mp4h/configure
PLIST_SUB+= ARCH=${PERL_ARCH}
diff --git a/www/xshttpd-devel/Makefile b/www/xshttpd-devel/Makefile
index fef2e81fb4af..964ca930202a 100644
--- a/www/xshttpd-devel/Makefile
+++ b/www/xshttpd-devel/Makefile
@@ -29,7 +29,6 @@ USE_BZIP2= yes
USE_RC_SUBR= xshttpd.sh
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
OPTIONS= SSL "Enable https support" On \
PCRE "Enable pcre rewriting support" On \
diff --git a/www/xshttpd/Makefile b/www/xshttpd/Makefile
index 16746a0cbe2e..52435d2da081 100644
--- a/www/xshttpd/Makefile
+++ b/www/xshttpd/Makefile
@@ -28,7 +28,6 @@ USE_BZIP2= yes
USE_RC_SUBR= xshttpd.sh
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
OPTIONS= SSL "Enable https support" On \
PCRE "Enable pcre rewriting support" On \