aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/anyterm/Makefile3
-rw-r--r--www/bozohttpd/Makefile3
-rw-r--r--www/dillo2/Makefile3
-rw-r--r--www/dtse/Makefile3
-rw-r--r--www/egueb/Makefile3
-rw-r--r--www/horde3-trean/Makefile3
-rw-r--r--www/kpartsplugin/Makefile3
-rw-r--r--www/mod_gnutls/Makefile3
-rw-r--r--www/mongrel2/Makefile3
-rw-r--r--www/multiwatch/Makefile3
-rw-r--r--www/npapi-xine/Makefile3
-rw-r--r--www/squid/Makefile3
-rw-r--r--www/squid32/Makefile3
-rw-r--r--www/squid33/Makefile3
-rw-r--r--www/wsmake/Makefile3
15 files changed, 15 insertions, 30 deletions
diff --git a/www/anyterm/Makefile b/www/anyterm/Makefile
index 07367ada7897..feec025e7f49 100644
--- a/www/anyterm/Makefile
+++ b/www/anyterm/Makefile
@@ -17,8 +17,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost-libs
USE_RC_SUBR= anytermd
-USE_BZIP2= yes
-USES= gmake iconv
+USES= gmake iconv tar:bzip2
USE_GCC= any
ALL_TARGET= default_target
PLIST_FILES= man/man1/anytermd.1.gz \
diff --git a/www/bozohttpd/Makefile b/www/bozohttpd/Makefile
index 4a5799bb5cd5..89a608bf8de3 100644
--- a/www/bozohttpd/Makefile
+++ b/www/bozohttpd/Makefile
@@ -12,14 +12,13 @@ COMMENT= The bozotic HTTP server
LICENSE= BSD2CLAUSE
-USE_BZIP2= YES
USE_RC_SUBR= bozohttpd
#options handling
OPTIONS_DEFINE= HTPASSWD SSL CGI
OPTIONS_DEFAULT= SSL CGI
-USES= uidfix
+USES= uidfix tar:bzip2
HTPASSWD_DESC= Enable htpassword support
SSL_DESC= Enable SSL support
diff --git a/www/dillo2/Makefile b/www/dillo2/Makefile
index 54631791c5b8..67108ec07adf 100644
--- a/www/dillo2/Makefile
+++ b/www/dillo2/Makefile
@@ -20,8 +20,7 @@ LICENSE= GPLv3
LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk
RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
-USES= gmake pkgconfig
-USE_BZIP2= yes
+USES= gmake pkgconfig tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/libexec
CONFLICTS= dillo-i18n-[0-9]* \
diff --git a/www/dtse/Makefile b/www/dtse/Makefile
index 7e3005349546..e367ff4d987a 100644
--- a/www/dtse/Makefile
+++ b/www/dtse/Makefile
@@ -20,8 +20,7 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.endif
-USES= gmake perl5
-USE_BZIP2= yes
+USES= gmake perl5 tar:bzip2
USE_AUTOTOOLS= aclocal:env automake:env autoconf:env
HAS_CONFIGURE= yes
diff --git a/www/egueb/Makefile b/www/egueb/Makefile
index 0c1aec0b8d46..66cb4b6dc020 100644
--- a/www/egueb/Makefile
+++ b/www/egueb/Makefile
@@ -14,9 +14,8 @@ LICENSE= LGPL21
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
DIST_SUBDIR= e17
-USE_BZIP2= yes
GNU_CONFIGURE= yes
-USES= bison gmake pathfix pkgconfig
+USES= bison gmake pathfix pkgconfig tar:bzip2
USE_EFL= eina enesim ender etch libtool_hack
USE_LDCONFIG= yes
diff --git a/www/horde3-trean/Makefile b/www/horde3-trean/Makefile
index f584f93902a3..d7d009b6a71e 100644
--- a/www/horde3-trean/Makefile
+++ b/www/horde3-trean/Makefile
@@ -12,8 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Bookmark manager
USE_HORDE= base pkg-message
-USE_BZIP2= yes
-USES= gettext
+USES= gettext tar:bzip2
PORTDOCS= CHANGES CREDITS INSTALL TODO README
NO_STAGE= yes
diff --git a/www/kpartsplugin/Makefile b/www/kpartsplugin/Makefile
index 02b81cc167ab..0165b80bdd08 100644
--- a/www/kpartsplugin/Makefile
+++ b/www/kpartsplugin/Makefile
@@ -12,8 +12,7 @@ COMMENT= Browser file viewer using KDE technology
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USE_QT4= corelib gui moc_build qmake_build rcc_build uic_build
-USE_BZIP2= yes
-USES= cmake webplugin:native
+USES= cmake webplugin:native tar:bzip2
CMAKE_ARGS= -DNSPLUGIN_INSTALL_DIR:PATH="${WEBPLUGIN_DIR}"
PORTDATE= 20120723
diff --git a/www/mod_gnutls/Makefile b/www/mod_gnutls/Makefile
index 977bdb1353ba..c756624f24ec 100644
--- a/www/mod_gnutls/Makefile
+++ b/www/mod_gnutls/Makefile
@@ -17,9 +17,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
-USE_BZIP2= yes
USE_AUTOTOOLS= libtool
-USES= pkgconfig
+USES= pkgconfig tar:bzip2
USE_APACHE= 22
GNU_CONFIGURE= yes
diff --git a/www/mongrel2/Makefile b/www/mongrel2/Makefile
index 9f66dcc8fec6..ed145a9d3283 100644
--- a/www/mongrel2/Makefile
+++ b/www/mongrel2/Makefile
@@ -15,8 +15,7 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libzmq.so:${PORTSDIR}/net/libzmq2 \
libsqlite3.so:${PORTSDIR}/databases/sqlite3
-USES= gmake
-USE_BZIP2= yes
+USES= gmake tar:bzip2
MAKE_FLAGS= freebsd
EXAMPLES_LIST= bbs \
chat \
diff --git a/www/multiwatch/Makefile b/www/multiwatch/Makefile
index 637adf914496..139cc0a7d68e 100644
--- a/www/multiwatch/Makefile
+++ b/www/multiwatch/Makefile
@@ -13,8 +13,7 @@ LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev
GNU_CONFIGURE= yes
-USES= pkgconfig
-USE_BZIP2= yes
+USES= pkgconfig tar:bzip2
USE_GNOME= glib20
# Help configure find libev.
diff --git a/www/npapi-xine/Makefile b/www/npapi-xine/Makefile
index 37e3dae4545c..d6fc9983072c 100644
--- a/www/npapi-xine/Makefile
+++ b/www/npapi-xine/Makefile
@@ -14,8 +14,7 @@ COMMENT= Embed Xine player into browser
LIB_DEPENDS= libxine.so:${PORTSDIR}/multimedia/libxine
-USES= pkgconfig webplugin:native
-USE_BZIP2= yes
+USES= pkgconfig webplugin:native tar:bzip2
GNU_CONFIGURE= yes
WEBPLUGIN_NAME= #
WEBPLUGIN_FILES= xineplugin.so
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 76de3e69854b..c9cc7f73976a 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -115,9 +115,8 @@ COMMENT= HTTP Caching Proxy
SQUID_STABLE_VER= 9
CONFLICTS_INSTALL= squid-2.[^7]* squid3?-* cacheboy-[0-9]* lusca-head-[0-9]*
-USES= perl5
+USES= perl5 tar:bzip2
GNU_CONFIGURE= yes
-USE_BZIP2= yes
USE_RC_SUBR= squid
SQUID_UID?= squid
diff --git a/www/squid32/Makefile b/www/squid32/Makefile
index 83102d08ecbb..1d355fdc8f01 100644
--- a/www/squid32/Makefile
+++ b/www/squid32/Makefile
@@ -44,9 +44,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
SQUID_STABLE_VER= 13
CONFLICTS_INSTALL= squid-2.[0-9].* squid33-* cacheboy-[0-9]* lusca-head-[0-9]*
-USES= perl5
+USES= perl5 tar:bzip2
GNU_CONFIGURE= yes
-USE_BZIP2= yes
USE_RC_SUBR= squid
USERS= squid
diff --git a/www/squid33/Makefile b/www/squid33/Makefile
index a2a5344b385d..7c789ad1bb29 100644
--- a/www/squid33/Makefile
+++ b/www/squid33/Makefile
@@ -44,9 +44,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
SQUID_STABLE_VER= 11
CONFLICTS_INSTALL= squid-2.[0-9].* squid32-* cacheboy-[0-9]* lusca-head-[0-9]*
-USES= perl5
+USES= perl5 tar:bzip2
GNU_CONFIGURE= yes
-USE_BZIP2= yes
USE_RC_SUBR= squid
USERS= squid
diff --git a/www/wsmake/Makefile b/www/wsmake/Makefile
index e63683ce7cee..cd29a7cf0309 100644
--- a/www/wsmake/Makefile
+++ b/www/wsmake/Makefile
@@ -11,8 +11,7 @@ COMMENT= Software for production and maintenance of web sites
OPTIONS_DEFINE= DOCS
-USES= gmake
-USE_BZIP2= yes
+USES= gmake tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gwsmake=no --enable-iswmake=no