aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/caja/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/caja/Makefile')
-rw-r--r--x11-fm/caja/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-fm/caja/Makefile b/x11-fm/caja/Makefile
new file mode 100644
index 000000000000..9ef3755b8ee3
--- /dev/null
+++ b/x11-fm/caja/Makefile
@@ -0,0 +1,44 @@
+# Created by: ade, archie
+# $FreeBSD$
+
+PORTNAME= caja
+PORTVERSION= 1.8.1
+CATEGORIES= x11-fm mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT?= File manager for the MATE desktop
+
+BUILD_DEPENDS= gtkdoc-check:${PORTSDIR}/textproc/gtk-doc
+LIB_DEPENDS= libexif.so:${PORTSDIR}/graphics/libexif \
+ libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique \
+ libexempi.so:${PORTSDIR}/textproc/exempi
+RUN_DEPENDS= ${LOCALBASE}/libexec/gvfsd:${PORTSDIR}/devel/gvfs
+
+PORTSCOUT= limitw:1,even
+
+USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
+ shared-mime-info tar:xz
+USE_MATE= desktop icontheme:run
+USE_XORG= ice x11 xrender
+USE_GNOME= glib20 gnomehier gtk20 intlhack introspection:build \
+ libxml2 pango
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-packagekit \
+ --with-gtk=2.0 \
+ --disable-gtk-doc \
+ --with-html-dir=${PREFIX}/share/doc
+INSTALLS_ICONS= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+
+GLIB_SCHEMAS= org.mate.caja.gschema.xml \
+ org.mate.media-handling.gschema.xml
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/caja/extensions-2.0
+
+.include <bsd.port.mk>