aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/xdiskusage/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/xdiskusage/Makefile')
-rw-r--r--x11-fm/xdiskusage/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11-fm/xdiskusage/Makefile b/x11-fm/xdiskusage/Makefile
index fbef0fddf3f5..766dfb74b6c7 100644
--- a/x11-fm/xdiskusage/Makefile
+++ b/x11-fm/xdiskusage/Makefile
@@ -9,7 +9,8 @@ PORTNAME= xdiskusage
PORTVERSION= 1.48
PORTREVISION= 6
CATEGORIES= x11-fm
-MASTER_SITES= http://xdiskusage.sourceforge.net/
+MASTER_SITES= http://xdiskusage.sourceforge.net/ \
+ http://www.gnu-darwin.org/distfiles/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
@@ -19,15 +20,17 @@ LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
USE_GMAKE= yes
+CXXFLAGS+= `fltk-config --cxxflags`
+LDFLAGS+= `fltk-config --ldflags`
+
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
PLIST_FILES= bin/xdiskusage
MAN1= xdiskusage.1
post-patch:
${REINPLACE_CMD} -e '22,24d' ${WRKSRC}/Makefile
-do-build:
- cd ${WRKSRC} && ${GMAKE} CXXFLAGS="`fltk-config --cxxflags`" LDFLAGS="`fltk-config --ldflags`"
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xdiskusage ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xdiskusage.1 ${MANPREFIX}/man/man1