aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/xfce4-fm/Makefile2
-rw-r--r--x11-fm/xfce4-fm/files/patch-libs-tubo.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/x11-fm/xfce4-fm/Makefile b/x11-fm/xfce4-fm/Makefile
index 8a648d01c1c6..db61c371faf8 100644
--- a/x11-fm/xfce4-fm/Makefile
+++ b/x11-fm/xfce4-fm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfce4-fm
PORTVERSION= 4.2.2
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= x11-fm xfce
MASTER_SITES= http://www.us.xfce.org/archive/xfce-${PORTVERSION}/src/ \
http://www.ca-us.xfce.org/archive/xfce-${PORTVERSION}/src/ \
diff --git a/x11-fm/xfce4-fm/files/patch-libs-tubo.c b/x11-fm/xfce4-fm/files/patch-libs-tubo.c
new file mode 100644
index 000000000000..07daa7eb8a7e
--- /dev/null
+++ b/x11-fm/xfce4-fm/files/patch-libs-tubo.c
@@ -0,0 +1,15 @@
+--- libs/tubo.c.orig Sat Oct 8 11:33:42 2005
++++ libs/tubo.c Sat Oct 8 11:34:37 2005
+@@ -296,9 +296,12 @@
+ printf("tubowait...\n");
+ #endif
+ #ifdef __FreeBSD__
++#include <osreldate.h>
++#if __FreeBSD_version < 503000
+ /* This apparently does the bug workaround for wait failure
+ * on FreeBSD 5.1: */
+ if (kill(PID,SIGCONT) == 0) return TRUE;
++#endif
+ #endif
+ #ifdef HYPER_DEBUG
+ printf("tubowait...dead...\n");