aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/XFree86-4-font100dpi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/XFree86-4-font100dpi/Makefile')
-rw-r--r--x11-fonts/XFree86-4-font100dpi/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-fonts/XFree86-4-font100dpi/Makefile b/x11-fonts/XFree86-4-font100dpi/Makefile
new file mode 100644
index 000000000000..fa24e91e46f6
--- /dev/null
+++ b/x11-fonts/XFree86-4-font100dpi/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: XFree86Xfont100dpi-4.0
+# Date created: 10 Oct 1999
+# Whom: taguchi@tohoku.iij.ad.jp
+#
+# $FreeBSD$
+#
+
+PORTNAME= font100dpi
+PORTVERSION= 4.0
+CATEGORIES= x11-fonts
+MASTER_SITES= ftp://ftp.xfree86.org/pub/XFree86/4.0/source/ \
+ ftp://ftp.freesoftware.com/pub/XFree86/4.0/source/ \
+ ftp://ftp.lip6.fr/pub/X11/XFree86/XFree86-4.0/source/ \
+ ftp://ftp.cs.tu-berlin.de/pub/X/XFree86/4.0/source/ \
+ ftp://sunsite.doc.ic.ac.uk/packages/XFree86/4.0/source/
+PKGNAMEPREFIX= XFree86-
+DISTFILES= X400src-2.tgz
+
+MAINTAINER= taguchi@tohoku.iij.ad.jp
+
+BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake-4 \
+ mkfontdir:${PORTSDIR}/x11/XFree86-4-libraries
+RUN_DEPENDS= ${X11BASE}/lib/X11/fonts/encodings/encodings.dir:${PORTSDIR}/x11-fonts/XFree86-4-fontEncodings
+
+PREFIX?= ${X11BASE}
+PROJECTROOT= -DProjectRoot=${PREFIX}
+MTREE_FILE= /etc/mtree/BSD.x11.dist
+DIST_SUBDIR= xc
+WRKSRC= ${WRKDIR}/xc/fonts/bdf/100dpi
+
+do-configure:
+ (cd ${WRKDIR}/xc/fonts/encodings && \
+ imake -DUseInstalled ${PROJECTROOT} -I${PREFIX}/lib/X11/config \
+ -DTOPDIR=../../.. -DCURDIR=.; \
+ ${MAKE} Makefiles ; \
+ ${MAKE} includes ; \
+ ${MAKE} depend)
+ (cd ${WRKSRC} && \
+ imake -DUseInstalled ${PROJECTROOT} -I${PREFIX}/lib/X11/config \
+ -DTOPDIR=../../.. -DCURDIR=.; \
+ ${MAKE} Makefiles ; \
+ ${MAKE} includes ; \
+ ${MAKE} depend)
+
+pre-build:
+ (cd ${WRKDIR}/xc/fonts/encodings && \
+ ${MAKE} all)
+
+.include <bsd.port.mk>