aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/linux-c6-hicolor-icon-theme/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/linux-c6-hicolor-icon-theme/Makefile')
-rw-r--r--x11-themes/linux-c6-hicolor-icon-theme/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-themes/linux-c6-hicolor-icon-theme/Makefile b/x11-themes/linux-c6-hicolor-icon-theme/Makefile
new file mode 100644
index 000000000000..31682d2ca6a7
--- /dev/null
+++ b/x11-themes/linux-c6-hicolor-icon-theme/Makefile
@@ -0,0 +1,27 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= hicolor-icon-theme
+PORTVERSION= 0.5
+CATEGORIES= x11-themes linux
+MASTER_SITES= # empty
+DISTFILES= # empty
+PKGNAMEPREFIX= linux-c6-
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= High-color icon theme shell from the FreeDesktop project
+
+CONFLICTS= linux-hicolor-icon-theme-[0-9]* linux-f8-hicolor-icon-theme-[0-9]*
+
+RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+
+NO_BUILD= yes
+USE_LINUX= c6
+USE_LINUX_PREFIX= yes
+PLIST_FILES= usr/share/icons/hicolor
+
+do-install:
+ ${INSTALL} -d ${STAGEDIR}${PREFIX}/usr/share/icons
+ ${LN} -fs ${LOCALBASE}/share/icons/hicolor ${STAGEDIR}${PREFIX}/usr/share/icons
+
+.include <bsd.port.mk>