aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk30/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtk30/Makefile')
-rw-r--r--x11-toolkits/gtk30/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index 909722844a22..209b3fc13016 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -75,6 +75,9 @@ CLOUDPRINT_LIB_DEPENDS= librest-0.7.so:devel/librest \
libsoup-2.4.so:devel/libsoup \
libjson-glib-1.0.so:devel/json-glib
+# don't explicitly disable debug, this causes segfaults. See ports r437293
+DEBUG_CONFIGURE_ON= --enable-debug=yes
+
WAYLAND_DESC= GDK Wayland backend
WAYLAND_CONFIGURE_ENABLE= wayland-backend
WAYLAND_BUILD_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols \
@@ -84,11 +87,6 @@ WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland \
WAYLAND_RUN_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols
WAYLAND_USE= GL=egl
-.include <bsd.port.options.mk>
-
-# don't explicitly disable debug, this causes segfaults. ports r437293
-DEBUG_CONFIGURE_ON= --enable-debug=yes
-
post-patch:
@${REINPLACE_CMD} -e 's|[{]libdir[}]/locale|{datadir}/locale|g' \
${WRKSRC}/configure