aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtkglarea--/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtkglarea--/Makefile')
-rw-r--r--x11-toolkits/gtkglarea--/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/x11-toolkits/gtkglarea--/Makefile b/x11-toolkits/gtkglarea--/Makefile
index a1876a631338..9ff656d2cf3a 100644
--- a/x11-toolkits/gtkglarea--/Makefile
+++ b/x11-toolkits/gtkglarea--/Makefile
@@ -21,7 +21,8 @@ LIB_DEPENDS= gtkmm.2:${PORTSDIR}/x11-toolkits/gtk-- \
USE_GL= yes
USE_GNOME= gtk12
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-lib-GL
INSTALLS_SHLIB= yes
@@ -30,4 +31,8 @@ CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lGL -lGLU \
${PTHREAD_LIBS}
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>