aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/guile-gtk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/guile-gtk/Makefile')
-rw-r--r--x11-toolkits/guile-gtk/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-toolkits/guile-gtk/Makefile b/x11-toolkits/guile-gtk/Makefile
new file mode 100644
index 000000000000..d44d91a470b5
--- /dev/null
+++ b/x11-toolkits/guile-gtk/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: guile-gtk
+# Version required: 0.17
+# Date created: 1 January 2000
+# Whom: Matt Braithwaite <mab@red-bean.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= guile-gtk-0.17
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://www.ping.de/sites/zagadka/guile-gtk/download/
+
+MAINTAINER= mab@red-bean.com
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ guile.6:${PORTSDIR}/lang/guile
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/giflib" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>