aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgnomeui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/libgnomeui/Makefile')
-rw-r--r--x11-toolkits/libgnomeui/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11-toolkits/libgnomeui/Makefile b/x11-toolkits/libgnomeui/Makefile
index f221c12df2f6..c7ac61fe1ea9 100644
--- a/x11-toolkits/libgnomeui/Makefile
+++ b/x11-toolkits/libgnomeui/Makefile
@@ -6,28 +6,30 @@
#
PORTNAME= libgnomeui
-PORTVERSION= 2.4.0.1
-PORTREVISION= 2
+PORTVERSION= 2.6.0
+PORTREVISION= 1
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.4
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.6
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Libraries for the GNOME GUI, a GNU desktop environment
-LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+LIB_DEPENDS+= gnome-keyring.0:${PORTSDIR}/security/gnomekeyring \
+ startup-notification-1.0:${PORTSDIR}/x11/startup-notification
RUN_DEPENDS= ${X11BASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_XPM= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier libbonoboui
+USE_GNOME= gnomeprefix gnomehack lthack gnomehier libbonoboui
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER=13
USE_BISON= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+PLIST_SUB= GTK_VERSION="2.4.0"
.include <bsd.port.mk>