aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/movingmotif/files/patch-demo::Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/movingmotif/files/patch-demo::Makefile.in')
-rw-r--r--x11-toolkits/movingmotif/files/patch-demo::Makefile.in41
1 files changed, 37 insertions, 4 deletions
diff --git a/x11-toolkits/movingmotif/files/patch-demo::Makefile.in b/x11-toolkits/movingmotif/files/patch-demo::Makefile.in
index 7282e838d2a3..12b637cc2ebe 100644
--- a/x11-toolkits/movingmotif/files/patch-demo::Makefile.in
+++ b/x11-toolkits/movingmotif/files/patch-demo::Makefile.in
@@ -1,7 +1,11 @@
---- demo/Makefile.in.orig Wed Sep 25 01:04:47 2002
-+++ demo/Makefile.in Sat Oct 12 15:10:51 2002
-@@ -114,12 +114,12 @@
- bin_PROGRAMS = ezdrawtest Scrollingtest histbar Rottest
+--- demo/Makefile.in.orig 2003-12-27 14:27:04.000000000 +0100
++++ demo/Makefile.in 2008-02-20 10:09:07.000000000 +0100
+@@ -111,20 +111,20 @@
+ xmVer = @xmVer@
+
+ SUBDIRS = mindsrc
+-bin_PROGRAMS = ezdrawtest Scrollingtest histbar Rottest Spectrtest
++bin_PROGRAMS = ezdrawtest Scrollingtest histbar Rottest
ezdrawtest_SOURCES = ezdrawtest.c
-ezdrawtest_LDADD = -L$(top_builddir)/src -lmovingmotif -L$(top_builddir)/demo/mindsrc -lmindsrc
@@ -16,3 +20,32 @@
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_CLEAN_FILES =
+ bin_PROGRAMS = ezdrawtest$(EXEEXT) Scrollingtest$(EXEEXT) \
+-histbar$(EXEEXT) Rottest$(EXEEXT) Spectrtest$(EXEEXT)
++histbar$(EXEEXT) Rottest$(EXEEXT)
+ PROGRAMS = $(bin_PROGRAMS)
+
+
+@@ -153,11 +153,6 @@
+ Rottest_LDADD = $(LDADD)
+ Rottest_DEPENDENCIES =
+ Rottest_LDFLAGS =
+-Spectrtest_SOURCES = histspectrtest.c
+-Spectrtest_OBJECTS = histspectrtest.$(OBJEXT)
+-Spectrtest_LDADD = $(LDADD)
+-Spectrtest_DEPENDENCIES =
+-Spectrtest_LDFLAGS =
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+@@ -268,10 +263,6 @@
+ @rm -f Rottest$(EXEEXT)
+ $(LINK) $(Rottest_LDFLAGS) $(Rottest_OBJECTS) $(Rottest_LDADD) $(LIBS)
+
+-Spectrtest$(EXEEXT): $(Spectrtest_OBJECTS) $(Spectrtest_DEPENDENCIES)
+- @rm -f Spectrtest$(EXEEXT)
+- $(LINK) $(Spectrtest_LDFLAGS) $(Spectrtest_OBJECTS) $(Spectrtest_LDADD) $(LIBS)
+-
+ # This directory's subdirectories are mostly independent; you can cd
+ # into them and run `make' without going through this Makefile.
+ # To change the values of `make' variables: instead of editing Makefiles,