aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/php-gtk2
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/php-gtk2')
-rw-r--r--x11-toolkits/php-gtk2/Makefile22
-rw-r--r--x11-toolkits/php-gtk2/files/php.ini-dist4
-rw-r--r--x11-toolkits/php-gtk2/pkg-plist32
3 files changed, 32 insertions, 26 deletions
diff --git a/x11-toolkits/php-gtk2/Makefile b/x11-toolkits/php-gtk2/Makefile
index 1194141a88d5..f88a1acd49b3 100644
--- a/x11-toolkits/php-gtk2/Makefile
+++ b/x11-toolkits/php-gtk2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= php-gtk
PORTVERSION= 0.5.2
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= http://gtk.php.net/distributions/ \
http://document-root.de/mirror/php-gtk/
@@ -20,8 +21,8 @@ BUILD_DEPENDS= automake:${PORTSDIR}/devel/automake \
automake14:${PORTSDIR}/devel/automake14 \
autoconf:${PORTSDIR}/devel/autoconf \
autoconf213:${PORTSDIR}/devel/autoconf213 \
- phpize:${PORTSDIR}/www/mod_php4
-RUN_DEPENDS= php:${PORTSDIR}/www/mod_php4
+ phpize:${PORTSDIR}/lang/php4-cli
+RUN_DEPENDS= php:${PORTSDIR}/lang/php4-cli
# Don't call autoconf directly, ./buildconf does this
GNU_CONFIGURE= yes
@@ -36,6 +37,7 @@ ENVSCE= -DHAVE_PHP_GTK=1 -DCOMPILE_DL_PHP_GTK=1 \
-DHAVE_SPANED=1 \
-DHAVE_SQPANE=1 \
-DHAVE_COMBOBUTTON=1
+
.if !defined(WITHOUT_LIBGLADE)
USE_GNOME+= libglade
ENVSCE+= -DHAVE_LIBGLADE
@@ -46,11 +48,17 @@ CONFIGURE_ARGS+= --disable-libglade
USE_GNOME+= gdkpixbuf
CONFIGURE_ARGS+= --enable-gdkpixbuf=shared
ENVSCE+= -DHAVE_GDKPIXBUF=1 -DPHP_GTK_COMPILE_DL_GDKPIXBUF=1
+PLIST_SUB+= GDKPIXBUF=""
+.else
+PLIST_SUB+= GDKPIXBUF="@comment "
.endif
.if !defined(WITHOUT_GTKHTML)
USE_GNOME+= gtkhtml
CONFIGURE_ARGS+= --enable-gtkhtml=shared
ENVSCE+= -DHAVE_HTML=1 -DPHP_GTK_COMPILE_DL_GTKHTML=1 -DGTKHTML_HAVE_GCONF=1 -I${X11BASE}/include/gal-1.0
+PLIST_SUB+= GTKHTML=""
+.else
+PLIST_SUB+= GTKHTML="@comment "
.endif
CONFIGURE_ENV= CPPFLAGS="${ENVSCE}"
@@ -75,19 +83,13 @@ pre-everything::
@${ECHO_MSG} '*********************************************************'
pre-configure:
+ @php ${SCRIPTDIR}/memlim.php
@${ECHO_MSG} "===> Building configuration files for ${PKGNAME}"
@(cd ${WRKSRC} && ./buildconf)
.for FILE in ${PIC2FIX}
@${REINPLACE_CMD} -e "s|-prefer-pic|${CFLAGS}|g" ${WRKSRC}/${FILE}
.endfor
-do-install:
- @$(MKDIR) -p ${PREFIX}/lib/php/extensions/
- @${INSTALL_PROGRAM} ${WRKSRC}/modules/php_gtk.so ${PREFIX}/lib/php/extensions/php_gtk.so
-# TODO: php_gtk_gdkpixbuf.so and php_gtk_gtkhtml.so are not installed
- @${MKDIR} ${PREFIX}/etc/php.gtk
- @${INSTALL_DATA} ${FILESDIR}/php.ini-dist ${PREFIX}/etc/php.gtk
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
@@ -96,6 +98,8 @@ post-install:
.endfor
@${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
.endif
+ @${MKDIR} ${PREFIX}/etc/php.gtk
+ @${INSTALL_DATA} ${FILESDIR}/php.ini-dist ${PREFIX}/etc/php.gtk
@${ECHO} ""
@${CAT} ${MASTERDIR}/pkg-message
@${ECHO} ""
diff --git a/x11-toolkits/php-gtk2/files/php.ini-dist b/x11-toolkits/php-gtk2/files/php.ini-dist
index 5a83aff35f92..c91f5dd05d70 100644
--- a/x11-toolkits/php-gtk2/files/php.ini-dist
+++ b/x11-toolkits/php-gtk2/files/php.ini-dist
@@ -265,7 +265,7 @@ variables_order = "EGPCS"
; You should do your best to write your scripts so that they do not require
; register_globals to be on; Using form variables as globals can easily lead
; to possible security problems, if the code is not very well thought of.
-register_globals = On
+; register_globals = On
; This directive tells PHP whether to declare the argv&argc variables (that
; would contain the GET information). If you don't use these variables, you
@@ -321,7 +321,7 @@ doc_root =
user_dir =
; Directory in which the loadable extensions (modules) reside.
-extension_dir = /usr/local/lib/php/extensions
+extension_dir = /usr/local/lib/php/20020429
; Whether or not to enable the dl() function. The dl() function does NOT work
; properly in multithreaded servers, such as IIS or Zeus, and is automatically
diff --git a/x11-toolkits/php-gtk2/pkg-plist b/x11-toolkits/php-gtk2/pkg-plist
index e567bec4654c..dbd98a8715be 100644
--- a/x11-toolkits/php-gtk2/pkg-plist
+++ b/x11-toolkits/php-gtk2/pkg-plist
@@ -1,17 +1,19 @@
etc/php.gtk/php.ini-dist
-lib/php/extensions/php_gtk.so
-%%PORTDOCS%%%%EXAMPLESDIR%%/combobutton.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/fileselection.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/gtk.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/hello.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/list.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/piemenu.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/scribble.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/scrollpane.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/spaned.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/sqpane.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/testgtkrc
-%%PORTDOCS%%%%EXAMPLESDIR%%/testgtkrc2
-%%PORTDOCS%%%%EXAMPLESDIR%%/window.xpm
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%GDKPIXBUF%%lib/php/20020429/gdkpixbuf.so
+%%GTKHTML%%lib/php/20020429/gtkhtml.so
+lib/php/20020429/php_gtk.so
+share/examples/php-gtk/combobutton.php
+share/examples/php-gtk/fileselection.php
+share/examples/php-gtk/gtk.php
+share/examples/php-gtk/hello.php
+share/examples/php-gtk/list.php
+share/examples/php-gtk/piemenu.php
+share/examples/php-gtk/scribble.php
+share/examples/php-gtk/scrollpane.php
+share/examples/php-gtk/spaned.php
+share/examples/php-gtk/sqpane.php
+share/examples/php-gtk/testgtkrc
+share/examples/php-gtk/testgtkrc2
+share/examples/php-gtk/window.xpm
+@dirrm share/examples/php-gtk
@dirrm etc/php.gtk