aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-wxPython4
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/py-wxPython4')
-rw-r--r--x11-toolkits/py-wxPython4/Makefile35
-rw-r--r--x11-toolkits/py-wxPython4/distinfo3
-rw-r--r--x11-toolkits/py-wxPython4/files/patch-build.py11
-rw-r--r--x11-toolkits/py-wxPython4/files/patch-sip_cpp_sip__gridwxGridEvent.cpp13
-rw-r--r--x11-toolkits/py-wxPython4/pkg-descr7
5 files changed, 69 insertions, 0 deletions
diff --git a/x11-toolkits/py-wxPython4/Makefile b/x11-toolkits/py-wxPython4/Makefile
new file mode 100644
index 000000000000..c69e0e30db46
--- /dev/null
+++ b/x11-toolkits/py-wxPython4/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= wxPython
+PORTVERSION= 4.1.1
+CATEGORIES= x11-toolkits python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 41
+DIST_SUBDIR= python
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= GUI toolkit for the Python programming language
+
+LICENSE= WXWINDOWS LGPL21+ GPLv2+
+LICENSE_COMB= multi
+LICENSE_NAME_WXWINDOWS= wxWindows Library Licence, Version 3.1
+LICENSE_FILE_WXWINDOWS= ${WRKSRC}/license/licence.txt
+LICENSE_PERMS_WXWINDOWS= dist-mirror pkg-mirror auto-accept
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pathlib2>0:devel/py-pathlib2@${PY_FLAVOR}
+
+USES= compiler:c++11-lib gl localbase pkgconfig python:3.6+
+USE_GL= glu
+USE_WX= 3.1
+USE_PYTHON= distutils autoplist
+
+OPTIONS_DEFINE= NLS
+
+NLS_USES= gettext
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|WX_CONFIG = 'wx-config'|WX_CONFIG = '${WX_CONFIG}'|" ${WRKSRC}/build.py
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR}/wx -name *.so -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-wxPython4/distinfo b/x11-toolkits/py-wxPython4/distinfo
new file mode 100644
index 000000000000..a796f2046b3d
--- /dev/null
+++ b/x11-toolkits/py-wxPython4/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1643317997
+SHA256 (python/wxPython-4.1.1.tar.gz) = 00e5e3180ac7f2852f342ad341d57c44e7e4326de0b550b9a5c4a8361b6c3528
+SIZE (python/wxPython-4.1.1.tar.gz) = 66043287
diff --git a/x11-toolkits/py-wxPython4/files/patch-build.py b/x11-toolkits/py-wxPython4/files/patch-build.py
new file mode 100644
index 000000000000..24b88f7e93ef
--- /dev/null
+++ b/x11-toolkits/py-wxPython4/files/patch-build.py
@@ -0,0 +1,11 @@
+--- build.py.orig 2019-05-21 23:12:12 UTC
++++ build.py
+@@ -401,7 +401,7 @@ def makeOptionParser():
+ ("mac_framework", (False, "Build wxWidgets as a Mac framework.")),
+ ("mac_arch", ("", "Comma separated list of architectures to build on Mac")),
+
+- ("use_syswx", (False, "Try to use an installed wx rather than building the "
++ ("use_syswx", (True, "Try to use an installed wx rather than building the "
+ "one in this source tree. The wx-config in {prefix}/bin "
+ "or the first found on the PATH determines which wx is "
+ "used. Implies --no_magic.")),
diff --git a/x11-toolkits/py-wxPython4/files/patch-sip_cpp_sip__gridwxGridEvent.cpp b/x11-toolkits/py-wxPython4/files/patch-sip_cpp_sip__gridwxGridEvent.cpp
new file mode 100644
index 000000000000..14a153c42943
--- /dev/null
+++ b/x11-toolkits/py-wxPython4/files/patch-sip_cpp_sip__gridwxGridEvent.cpp
@@ -0,0 +1,13 @@
+--- sip/cpp/sip_gridwxGridEvent.cpp.orig 2022-01-27 22:07:16 UTC
++++ sip/cpp/sip_gridwxGridEvent.cpp
+@@ -32,8 +32,8 @@ class sipwxGridEvent : public ::wxGridEvent (public)
+ * this class.
+ */
+ protected:
+- int GetRow() SIP_OVERRIDE;
+- int GetCol() SIP_OVERRIDE;
++ int GetRow();
++ int GetCol();
+ ::wxEvent* Clone() const SIP_OVERRIDE;
+ ::wxEventCategory GetEventCategory() const SIP_OVERRIDE;
+
diff --git a/x11-toolkits/py-wxPython4/pkg-descr b/x11-toolkits/py-wxPython4/pkg-descr
new file mode 100644
index 000000000000..027967687f5c
--- /dev/null
+++ b/x11-toolkits/py-wxPython4/pkg-descr
@@ -0,0 +1,7 @@
+wxPython is a GUI toolkit for the Python programming language. It allows Python
+programmers to create programs with a robust, highly functional graphical user
+interface, simply and easily. It is implemented as a Python extension module
+(native code) that wraps the popular wxWidgets cross platform GUI library, which
+is written in C++.
+
+WWW: http://www.wxpython.org