aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt33/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/qt33/Makefile')
-rw-r--r--x11-toolkits/qt33/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index b09f9a27cbb3..09ff964a0f3b 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -8,7 +8,7 @@
PORTNAME= qt
PORTVERSION= 3.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= x11-toolkits
MASTER_SITES= ftp://ftp.trolltech.com/qt/source/ \
ftp://ftp.silug.org/pub/qt/ \
@@ -138,6 +138,11 @@ post-patch:
.endif
@${REINPLACE_CMD} -e 's|^ cd qmake.*||' ${WRKSRC}/Makefile
+post-configure:
+ @${REINPLACE_CMD} -e \
+ 's|/usr/X11R6/lib/pkgconfig/qt-mt.pc|${PREFIX}/libdata/pkgconfig/qt-mt.pc|g' \
+ ${WRKSRC}/src/Makefile
+
post-build:
.for tool in makeqpf mergetr msg2qm qembed qvfb
@cd ${WRKSRC}/tools/${tool}; ${SETENV} ${MAKE_ENV} ${MAKE}