aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/ruby-gtk2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/ruby-gtk2/Makefile')
-rw-r--r--x11-toolkits/ruby-gtk2/Makefile35
1 files changed, 11 insertions, 24 deletions
diff --git a/x11-toolkits/ruby-gtk2/Makefile b/x11-toolkits/ruby-gtk2/Makefile
index 66f5def898a0..4863ee7f8080 100644
--- a/x11-toolkits/ruby-gtk2/Makefile
+++ b/x11-toolkits/ruby-gtk2/Makefile
@@ -1,11 +1,11 @@
-# New ports collection makefile for: ruby-gtk
+# New ports collection makefile for: Ruby/GTK2
# Date created: 19 April 1999
# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
#
# $FreeBSD$
#
-PORTNAME= gtk
+PORTNAME= gtk2
PORTVERSION= ${RUBY_GNOME_PORTVERSION}
CATEGORIES= x11-toolkits ruby
MASTER_SITES= ${RUBY_GNOME_MASTER_SITES}
@@ -16,42 +16,29 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
+LIB_DEPENDS= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/glib2.so:${PORTSDIR}/devel/ruby-glib2
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
USE_XLIB= yes
-USE_GNOMENG= yes
-USE_GNOME= gtk12
-.include "${.CURDIR}/../../x11/ruby-gnome/Makefile.common"
+.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
-WRKSRC= ${RUBY_GNOME_WRKSRC}/${PORTNAME}
-CONFIGURE_ARGS= --with-gtk-config=${GTK_CONFIG}
+WRKSRC= ${RUBY_GNOME_WRKSRC}/gtk
INSTALL_TARGET= site-install
-DOCS_EN= BUGS \
- ChangeLog \
- NEWS \
- README \
- README.EXT \
- ToDo
-DOCS_JA= README.EXT.ja
-
-post-extract:
- ${MKDIR} ${WRKSRC}/sample/browser
- ${MV} ${WRKSRC}/doc/*.rb ${WRKSRC}/sample/browser/
+DOCS= ChangeLog \
+ README
post-install:
- ${INSTALL_DATA} ${WRKSRC}/lib/gtkcompat.rb ${RUBY_SITELIBDIR}/
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${CP} -R ${WRKSRC}/sample/* ${RUBY_MODEXAMPLESDIR}/
- ${MKDIR} ${RUBY_MODDOCDIR}/ja
-.for f in ${DOCS_EN}
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
-.for f in ${DOCS_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
-.endfor
.endif
.include <bsd.port.mk>