aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/tile/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/tile/Makefile')
-rw-r--r--x11-toolkits/tile/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-toolkits/tile/Makefile b/x11-toolkits/tile/Makefile
new file mode 100644
index 000000000000..c2ea14e97491
--- /dev/null
+++ b/x11-toolkits/tile/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: tile
+# Date created: 18 July 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tile
+PORTVERSION= 0.7.8
+CATEGORIES= x11-toolkits tk84
+MASTER_SITES= SF/tktable
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Themed widget set for Tk
+
+LIB_DEPENDS= tk${USE_TK}.1:${PORTSDIR}/x11-toolkits/tk${USE_TK}
+
+USE_TK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl${TK_VER} \
+ --with-tk=${LOCALBASE}/lib/tk${TK_VER} \
+ --exec-prefix=${PREFIX} --enable-shared
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${TCL_INCLUDES} ${TK_INCLUDES}"
+TCL_INCLUDES= -I${LOCALBASE}/include/tcl${TK_VER} -I${LOCALBASE}/include/tcl${TK_VER}/generic
+TK_INCLUDES= -I${LOCALBASE}/include/tk${TK_VER} -I${LOCALBASE}/include/tk${TK_VER}/generic
+TKPKG= ${PORTNAME}${PORTVERSION}
+PLIST_SUB= VER=${PORTVERSION} TKPKG=${TKPKG}
+USE_LDCONFIG= ${PREFIX}/lib/${TKPKG}
+
+post-install:
+ @${LN} -sf ${USE_LDCONFIG}/lib${TKPKG}.so ${USE_LDCONFIG}/lib${TKPKG}.so.0
+
+.include <bsd.port.mk>