aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/tk84
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/tk84')
-rw-r--r--x11-toolkits/tk84/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/x11-toolkits/tk84/Makefile b/x11-toolkits/tk84/Makefile
index a506af599cad..db33cc966b00 100644
--- a/x11-toolkits/tk84/Makefile
+++ b/x11-toolkits/tk84/Makefile
@@ -346,16 +346,13 @@ MLINKS= 3DBorder.3 Tk_Alloc3DBorderFromObj.3 \
.include <bsd.port.pre.mk>
-.if defined(WITH_THREADS)
+pre-everything::
+ @if ${TEST} -e "${NONEXISTENT}"; then ${ECHO_MSG} "=== Aborted, please remove ${NONEXISTENT}"; exit 1; fi
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
-.endif
-
-pre-extract:
- @if test -e "${NONEXISTENT}"; then echo "=== Aborted, please remove ${NONEXISTENT}"; exit 1; fi
-
post-configure:
${REINPLACE_CMD} -e 's=${WRKDIRPREFIX}${PORTSDIR}=$${WRKDIRPREFIX}${PORTSDIR}=' \
${WRKSRC}/tkConfig.sh
@@ -367,7 +364,7 @@ post-install:
.endif
test:
- cd ${WRKSRC}; make test
+ cd ${WRKSRC}; ${MAKE} test
${ECHO_CMD} "package require Tk" | tclsh${TK_VER}
${ECHO_CMD} "load libtk${SHORT_TK_VER}.so" | tclsh${TK_VER}