aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gnustep-back/Makefile11
-rw-r--r--x11-toolkits/gnustep-gui/Makefile15
-rw-r--r--x11-toolkits/gtoolkit/Makefile15
3 files changed, 17 insertions, 24 deletions
diff --git a/x11-toolkits/gnustep-back/Makefile b/x11-toolkits/gnustep-back/Makefile
index 1ac2b86f3ea6..074107dad0f6 100644
--- a/x11-toolkits/gnustep-back/Makefile
+++ b/x11-toolkits/gnustep-back/Makefile
@@ -36,6 +36,11 @@ CONFIGURE_ARGS+= --with-jpeg-include=${LOCALBASE}/include
#CPPFLAGS+= -I${LOCALBASE}/include/freetype2
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_GUI= yes
+USE_GNUSTEP_CONFIGURE= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
MAKEFILE=
MAKE_FLAGS+= OPTFLAG="${CFLAGS} -I${X11BASE}/include"
BREAKS_IF_PEDANTIC= yes
@@ -68,12 +73,6 @@ PLIST_SUB+= USE_XLIB="" USE_XDPS="@comment " USE_ART="@comment "
MAKE_ENV+= ADDITIONAL_LDFLAGS=-lcipher
.endif
-USE_GNUSTEP_GUI= yes
-USE_GNUSTEP_CONFIGURE= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
-.include "${PORTSDIR}/devel/gnustep/bsd.gnustep.mk"
-
post-extract:
.for file in config.guess config.sub install-sh
@${CP} ${PREFIX}/System/Makefiles/${file} ${WRKSRC}
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index a9eb6fe2361a..bb1f45227263 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -31,18 +31,15 @@ CONFIGURE_ARGS+= --with-tiff-include=${LOCALBASE}/include
CONFIGURE_ARGS+= --with-jpeg-library=${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-jpeg-include=${LOCALBASE}/include
USE_GMAKE= yes
-MAKEFILE=
-MAKE_FLAGS+= OPTFLAG="${CFLAGS}"
-BREAKS_IF_PEDANTIC= yes
-EXTRA_FIX= ${WRKSRC}/Tools/gsnd/portaudio/pa_unix_oss/Makefile
-
-.include <bsd.port.pre.mk>
-
+USE_GNUSTEP= yes
USE_GNUSTEP_CONFIGURE= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_BASE= yes
-.include "${PORTSDIR}/devel/gnustep/bsd.gnustep.mk"
+MAKEFILE=
+MAKE_FLAGS+= OPTFLAG="${CFLAGS}"
+BREAKS_IF_PEDANTIC= yes
+EXTRA_FIX= ${WRKSRC}/Tools/gsnd/portaudio/pa_unix_oss/Makefile
post-extract:
.for file in config.guess config.sub install-sh
@@ -59,4 +56,4 @@ test:
@(cd ${WRKSRC}/Tools/gsnd/portaudio/pa_unix_oss && \
${GMAKE} && ./patest)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gtoolkit/Makefile b/x11-toolkits/gtoolkit/Makefile
index a9c5c76b9a7b..7bd074563aa8 100644
--- a/x11-toolkits/gtoolkit/Makefile
+++ b/x11-toolkits/gtoolkit/Makefile
@@ -18,6 +18,11 @@ PREFIX= ${LOCALBASE}/GNUstep
NO_MTREE= yes
USE_GMAKE= yes
USE_GNOME= gtk12
+USE_GNUSTEP= yes
+USE_GNUSTEP_BASE= yes
+USE_GNUSTEP_CONFIGURE= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
GNU_CONFIGURE= yes
LDCONFIG_DIRS= ${LOCALLIBDIR}
INSTALLS_SHLIB= yes
@@ -34,12 +39,4 @@ post-patch:
> ${CONFIGURE_WRKSRC}/configure
${CHMOD} +x ${CONFIGURE_WRKSRC}/configure
-.include <bsd.port.pre.mk>
-
-USE_GNUSTEP_BASE= yes
-USE_GNUSTEP_CONFIGURE= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
-.include "${PORTSDIR}/devel/gnustep/bsd.gnustep.mk"
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>