aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt23/Makefile4
-rw-r--r--x11-toolkits/qt30/Makefile4
-rw-r--r--x11-toolkits/qt31/Makefile4
-rw-r--r--x11-toolkits/qt32/Makefile4
-rw-r--r--x11-toolkits/qt33/Makefile4
5 files changed, 20 insertions, 0 deletions
diff --git a/x11-toolkits/qt23/Makefile b/x11-toolkits/qt23/Makefile
index cf6aeed7f474..dc9c66cf6823 100644
--- a/x11-toolkits/qt23/Makefile
+++ b/x11-toolkits/qt23/Makefile
@@ -23,6 +23,10 @@ LIB_DEPENDS= mng.1:${PORTSDIR}/graphics/libmng \
BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
.endif
+.if ${OSVERSION} >= 500000
+NO_QT_OBJPRELINK= yes
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
USE_GMAKE= yes
diff --git a/x11-toolkits/qt30/Makefile b/x11-toolkits/qt30/Makefile
index cf6aeed7f474..dc9c66cf6823 100644
--- a/x11-toolkits/qt30/Makefile
+++ b/x11-toolkits/qt30/Makefile
@@ -23,6 +23,10 @@ LIB_DEPENDS= mng.1:${PORTSDIR}/graphics/libmng \
BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
.endif
+.if ${OSVERSION} >= 500000
+NO_QT_OBJPRELINK= yes
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
USE_GMAKE= yes
diff --git a/x11-toolkits/qt31/Makefile b/x11-toolkits/qt31/Makefile
index cf6aeed7f474..dc9c66cf6823 100644
--- a/x11-toolkits/qt31/Makefile
+++ b/x11-toolkits/qt31/Makefile
@@ -23,6 +23,10 @@ LIB_DEPENDS= mng.1:${PORTSDIR}/graphics/libmng \
BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
.endif
+.if ${OSVERSION} >= 500000
+NO_QT_OBJPRELINK= yes
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
USE_GMAKE= yes
diff --git a/x11-toolkits/qt32/Makefile b/x11-toolkits/qt32/Makefile
index cf6aeed7f474..dc9c66cf6823 100644
--- a/x11-toolkits/qt32/Makefile
+++ b/x11-toolkits/qt32/Makefile
@@ -23,6 +23,10 @@ LIB_DEPENDS= mng.1:${PORTSDIR}/graphics/libmng \
BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
.endif
+.if ${OSVERSION} >= 500000
+NO_QT_OBJPRELINK= yes
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
USE_GMAKE= yes
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index cf6aeed7f474..dc9c66cf6823 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -23,6 +23,10 @@ LIB_DEPENDS= mng.1:${PORTSDIR}/graphics/libmng \
BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
.endif
+.if ${OSVERSION} >= 500000
+NO_QT_OBJPRELINK= yes
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
USE_GMAKE= yes