aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e17-module-penguins/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/e17-module-penguins/Makefile')
-rw-r--r--x11-wm/e17-module-penguins/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-wm/e17-module-penguins/Makefile b/x11-wm/e17-module-penguins/Makefile
new file mode 100644
index 000000000000..7b934aa0b7db
--- /dev/null
+++ b/x11-wm/e17-module-penguins/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: e17-module-penguins
+# Date created: 07 January 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= penguins
+PORTVERSION= 20101003
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= http://files.roorback.net/e17/2010-10-03/modules/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= An e17 module that displays fancy penguins walking around your desktop
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= e17
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget pkgconfig
+USE_EFL= edje libtool_hack modarch_hack
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>