aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/kdeartwork3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/kdeartwork3/Makefile')
-rw-r--r--x11-wm/kdeartwork3/Makefile23
1 files changed, 22 insertions, 1 deletions
diff --git a/x11-wm/kdeartwork3/Makefile b/x11-wm/kdeartwork3/Makefile
index 85bf2299441f..acbc259570da 100644
--- a/x11-wm/kdeartwork3/Makefile
+++ b/x11-wm/kdeartwork3/Makefile
@@ -26,6 +26,27 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib/kde3
+KDE_BUILD_PLIST=yes
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if exists(${X11BASE}/bin/xscreensaver)
+WITH_XS= yes
+.endif # exists(${X11BASE}/bin/xscreensaver)
+
+.if exists(${X11BASE}/bin/screensaver-properties-capplet)
+WITH_XSGNOME= yes
+.endif # exists(${X11BASE}/bin/screensaver-properties-capplet)
+
+.if defined(WITH_XS) && !defined(WITH_XSGNOME)
+BUILD_DEPENDS+= xscreensaver:${PORTSDIR}/x11/xscreensaver
+PLIST_APPEND+= plist.xs
+.endif # defined(WITH_XS)
+
+.if defined(WITH_XSGNOME)
+BUILD_DEPENDS+= screensaver-properties-capplet:${PORTSDIR}/x11/xscreensaver-gnome
+PLIST_APPEND+= plist.xs
+.endif # defined(WITH_XSGNOME)
+
+.include <bsd.port.post.mk>