aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/wmg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/wmg/Makefile')
-rw-r--r--x11-wm/wmg/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/x11-wm/wmg/Makefile b/x11-wm/wmg/Makefile
index 927fd0862190..2f91fa57f84a 100644
--- a/x11-wm/wmg/Makefile
+++ b/x11-wm/wmg/Makefile
@@ -17,16 +17,14 @@ COMMENT= Small GTK-based GNOME-compliant window manager
USE_X_PREFIX= yes
USE_XPM= yes
+USE_GNOME= gnomehack gnomelibs gnomeprefix
USE_GMAKE= yes
-USE_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}"
-.include <bsd.port.pre.mk>
+CFLAGS+= -fpermissive
-.if ${OSVERSION} > 500000
-BROKEN= "Does not compile"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>