aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/ctwm/Makefile1
-rw-r--r--x11-wm/ctwm/files/patch-util.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/x11-wm/ctwm/Makefile b/x11-wm/ctwm/Makefile
index e263f61827bb..e84c349e8fd8 100644
--- a/x11-wm/ctwm/Makefile
+++ b/x11-wm/ctwm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ctwm
PORTVERSION= 3.8.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11-wm
MASTER_SITES= http://ctwm.free.lp.se/dist/ \
diff --git a/x11-wm/ctwm/files/patch-util.c b/x11-wm/ctwm/files/patch-util.c
new file mode 100644
index 000000000000..f460a7e0bdf7
--- /dev/null
+++ b/x11-wm/ctwm/files/patch-util.c
@@ -0,0 +1,11 @@
+--- util.c.orig 2012-01-08 16:51:48.245308175 -0600
++++ util.c 2012-01-08 16:51:52.168309618 -0600
+@@ -3941,7 +3941,7 @@
+ #ifdef JPEG
+
+ unsigned short int *buffer_16bpp;
+-long *buffer_32bpp;
++uint32_t *buffer_32bpp;
+
+ static void convert_for_16 (int w, int x, int y, int r, int g, int b) {
+ buffer_16bpp [y * w + x] = ((r >> 3) << 11) + ((g >> 2) << 5) + (b >> 3);