aboutsummaryrefslogtreecommitdiff
path: root/x11/gcursor
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gcursor')
-rw-r--r--x11/gcursor/Makefile8
-rw-r--r--x11/gcursor/files/patch-src::gcursor.c11
2 files changed, 10 insertions, 9 deletions
diff --git a/x11/gcursor/Makefile b/x11/gcursor/Makefile
index 3ec776c87920..b535b53a2884 100644
--- a/x11/gcursor/Makefile
+++ b/x11/gcursor/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcursor
PORTVERSION= 0.061
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11 gnome
MASTER_SITES= http://download.qballcow.nl/programs/gcursor/
@@ -17,7 +17,7 @@ COMMENT= A mouse cursor theme selector for GNOME
RUN_DEPENDS= file-roller:${PORTSDIR}/archivers/file-roller
USE_GMAKE= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GNOME= gnomehack gnomeprefix gnometarget intlhack libgnomeui
USE_GETTEXT= yes
GNU_CONFIGURE= yes
@@ -27,8 +27,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
DOCS= AUTHORS COPYING ChangeLog INSTALL TODO
post-patch:
- @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
- ${WRKSRC}/src/gcursor.c
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/src/gcursor.c
@${REINPLACE_CMD} -e 's|share/applications|share/gnome/applications|g' \
${WRKSRC}/data/Makefile.in
diff --git a/x11/gcursor/files/patch-src::gcursor.c b/x11/gcursor/files/patch-src::gcursor.c
index e5ee235e98af..583eac0fd36d 100644
--- a/x11/gcursor/files/patch-src::gcursor.c
+++ b/x11/gcursor/files/patch-src::gcursor.c
@@ -1,6 +1,6 @@
---- src/gcursor.c.orig Mon Sep 20 14:34:20 2004
-+++ src/gcursor.c Mon Sep 20 14:34:25 2004
-@@ -32,29 +32,21 @@
+--- src/gcursor.c.orig Thu Aug 26 05:35:55 2004
++++ src/gcursor.c Thu Jul 27 13:25:46 2006
+@@ -32,29 +32,22 @@
#warning move this into gconf
char *paths[] = {
@@ -9,6 +9,7 @@
- "/usr/Xorg/lib/X11/icons/",
- "/usr/local/share/icons/",
- "/usr/share/icons/",
++ "%%LOCALBASE%%/lib/X11/icons/",
+ "%%X11BASE%%/lib/X11/icons/",
"%s/.icons/",
NULL
@@ -38,7 +39,7 @@
}
-@@ -85,7 +77,7 @@
+@@ -85,7 +78,7 @@
filename = g_shell_quote(gtk_file_selection_get_filename(GTK_FILE_SELECTION(fs)));
#endif
@@ -47,7 +48,7 @@
filename);
g_free(filename);
-@@ -281,7 +273,7 @@
+@@ -281,7 +274,7 @@
for (iterator = paths; *iterator; iterator++)
{