aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-applets/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnome-applets/Makefile')
-rw-r--r--x11/gnome-applets/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 0b692899a299..17d90546f04b 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -39,9 +39,9 @@ USE_GSTREAMER= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-mixer-applet \
--disable-networkmanager
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- OS_SYS="/usr/include"
+CONFIGURE_ENV= OS_SYS="/usr/include"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
GCONF_SCHEMAS= charpick.schemas drivemount.schemas geyes.schemas \
mixer.schemas multiload.schemas stickynotes.schemas
@@ -61,7 +61,7 @@ LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
.endif
.if ${ARCH} != "i386" && ${ARCH} != "amd64"
-CONFIGURE_ENV+= CFLAGS="${CFLAGS} -fPIC"
+CFLAGS+= -fPIC
PLIST_SUB= BATTERY="@comment "
.else
GCONF_SCHEMAS+= battstat.schemas