aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-menus
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnome-menus')
-rw-r--r--x11/gnome-menus/Makefile22
-rw-r--r--x11/gnome-menus/distinfo6
-rw-r--r--x11/gnome-menus/files/patch-simple-editor_GMenuSimpleEditor_menutreemodel.py4
-rw-r--r--x11/gnome-menus/pkg-plist66
4 files changed, 77 insertions, 21 deletions
diff --git a/x11/gnome-menus/Makefile b/x11/gnome-menus/Makefile
index 7adeffeebdc0..26c86ecf496d 100644
--- a/x11/gnome-menus/Makefile
+++ b/x11/gnome-menus/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnome-menus/Makefile,v 1.29 2006/04/13 13:04:49 ahze Exp $
+# $MCom: ports/x11/gnome-menus/Makefile,v 1.39 2006/10/03 11:32:43 ahze Exp $
#
PORTNAME= gnome-menus
-PORTVERSION= 2.14.3
+PORTVERSION= 2.16.1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -18,12 +18,12 @@ COMMENT= Implementation of the FreeDesktop Desktop Menu Spec
USE_GETTEXT= yes
USE_BZIP2= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomevfs2 ltverhack
USE_AUTOTOOLS= libtool:15
USE_PYTHON= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -34,16 +34,24 @@ USE_FAM= yes
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/share/gnome|${X11BASE}/share/gnome|g' \
+ @${REINPLACE_CMD} -e 's|applications.menu||' \
+ ${WRKSRC}/layout/Makefile.in
+ @${REINPLACE_CMD} -e 's|applications.menu|gnome-applications.menu|' \
+ ${WRKSRC}/util/test-menu-spec.c
+ @${REINPLACE_CMD} -e 's|/usr/share/gnome|${LOCALBASE}/share/gnome|g' \
${WRKSRC}/layout/applications.menu \
${WRKSRC}/layout/settings.menu
@${SED} -e 's|/usr/local|${LOCALBASE}|g' \
< ${FILESDIR}/KDE.directory > ${WRKSRC}/KDE.directory
- @${REINPLACE_CMD} -e s'|%%X11BASE%%|${X11BASE}|g' \
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/simple-editor/GMenuSimpleEditor/menutreemodel.py
post-install:
@${MKDIR} ${PREFIX}/share/gnome/desktop-directories
- @${INSTALL_DATA} ${WRKSRC}/KDE.directory ${PREFIX}/share/gnome/desktop-directories
+ @${INSTALL_DATA} ${WRKSRC}/layout/applications.menu \
+ ${PREFIX}/etc/xdg/menus/gnome-applications.menu
+ @${INSTALL_DATA} ${WRKSRC}/KDE.directory \
+ ${PREFIX}/share/gnome/desktop-directories
.include <bsd.port.post.mk>
diff --git a/x11/gnome-menus/distinfo b/x11/gnome-menus/distinfo
index f0a6d4915c21..40c830018d7e 100644
--- a/x11/gnome-menus/distinfo
+++ b/x11/gnome-menus/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-menus-2.14.3.tar.bz2) = 9926e7ad14255d1a08c7e774052f8a3a
-SHA256 (gnome2/gnome-menus-2.14.3.tar.bz2) = 0bc939a5c8347cfcbd83087f05f517b3a093515a93c104b833f2b05564df14d9
-SIZE (gnome2/gnome-menus-2.14.3.tar.bz2) = 406000
+MD5 (gnome2/gnome-menus-2.16.1.tar.bz2) = a5c467abe68003d23ec09a795ebfd29f
+SHA256 (gnome2/gnome-menus-2.16.1.tar.bz2) = 72238f33406ada505fde8555ff93c00e7fec055a41500339b434c5445b09c87b
+SIZE (gnome2/gnome-menus-2.16.1.tar.bz2) = 416053
diff --git a/x11/gnome-menus/files/patch-simple-editor_GMenuSimpleEditor_menutreemodel.py b/x11/gnome-menus/files/patch-simple-editor_GMenuSimpleEditor_menutreemodel.py
index 2306f060952e..5620119697f0 100644
--- a/x11/gnome-menus/files/patch-simple-editor_GMenuSimpleEditor_menutreemodel.py
+++ b/x11/gnome-menus/files/patch-simple-editor_GMenuSimpleEditor_menutreemodel.py
@@ -5,7 +5,7 @@
conf_dirs = os.environ["XDG_CONFIG_DIRS"]
if not conf_dirs:
- conf_dirs = "/etc/xdg"
-+ conf_dirs = "%%X11BASE%%/etc/xdg"
++ conf_dirs = "%%LOCALBASE%%/etc/xdg"
for conf_dir in conf_dirs.split (":"):
menu_file_path = os.path.join (conf_dir, "menus", menu_file)
@@ -14,7 +14,7 @@
data_dirs = os.environ["XDG_DATA_DIRS"]
if not data_dirs:
- data_dirs = "/usr/local/share/:/usr/share/"
-+ data_dirs = "%%X11BASE%%/share/gnome/:/usr/local/share/gnome/:%%X11BASE%%/share/:/usr/local/share/:/usr/share/"
++ data_dirs = "%%X11BASE%%/share/gnome/:%%LOCALBASE%%/share/gnome/:%%X11BASE%%/share/:%%LOCALBASE%%/share/:/usr/share/"
for data_dir in data_dirs.split (":"):
retval = load_icon_from_path (os.path.join (data_dir, "pixmaps", icon_value))
diff --git a/x11/gnome-menus/pkg-plist b/x11/gnome-menus/pkg-plist
index 819f01166655..1a63a7cb3952 100644
--- a/x11/gnome-menus/pkg-plist
+++ b/x11/gnome-menus/pkg-plist
@@ -1,5 +1,5 @@
bin/gnome-menu-spec-test
-etc/xdg/menus/applications.menu
+etc/xdg/menus/gnome-applications.menu
etc/xdg/menus/preferences.menu
etc/xdg/menus/settings.menu
include/gnome-menus/gmenu-tree.h
@@ -30,8 +30,10 @@ share/gnome/desktop-directories/Settings.directory
share/gnome/desktop-directories/System-Settings.directory
share/gnome/desktop-directories/System-Tools.directory
share/locale/ar/LC_MESSAGES/gnome-menus.mo
+share/locale/be/LC_MESSAGES/gnome-menus.mo
share/locale/bg/LC_MESSAGES/gnome-menus.mo
share/locale/bn/LC_MESSAGES/gnome-menus.mo
+share/locale/bn_IN/LC_MESSAGES/gnome-menus.mo
share/locale/br/LC_MESSAGES/gnome-menus.mo
share/locale/ca/LC_MESSAGES/gnome-menus.mo
share/locale/cs/LC_MESSAGES/gnome-menus.mo
@@ -48,6 +50,7 @@ share/locale/eu/LC_MESSAGES/gnome-menus.mo
share/locale/fa/LC_MESSAGES/gnome-menus.mo
share/locale/fi/LC_MESSAGES/gnome-menus.mo
share/locale/fr/LC_MESSAGES/gnome-menus.mo
+share/locale/gn/LC_MESSAGES/gnome-menus.mo
share/locale/gl/LC_MESSAGES/gnome-menus.mo
share/locale/gu/LC_MESSAGES/gnome-menus.mo
share/locale/he/LC_MESSAGES/gnome-menus.mo
@@ -65,12 +68,15 @@ share/locale/lt/LC_MESSAGES/gnome-menus.mo
share/locale/lv/LC_MESSAGES/gnome-menus.mo
share/locale/mg/LC_MESSAGES/gnome-menus.mo
share/locale/mk/LC_MESSAGES/gnome-menus.mo
+share/locale/ml/LC_MESSAGES/gnome-menus.mo
+share/locale/mn/LC_MESSAGES/gnome-menus.mo
share/locale/mr/LC_MESSAGES/gnome-menus.mo
share/locale/ms/LC_MESSAGES/gnome-menus.mo
share/locale/nb/LC_MESSAGES/gnome-menus.mo
share/locale/ne/LC_MESSAGES/gnome-menus.mo
share/locale/nl/LC_MESSAGES/gnome-menus.mo
share/locale/nn/LC_MESSAGES/gnome-menus.mo
+share/locale/or/LC_MESSAGES/gnome-menus.mo
share/locale/pa/LC_MESSAGES/gnome-menus.mo
share/locale/pl/LC_MESSAGES/gnome-menus.mo
share/locale/pt/LC_MESSAGES/gnome-menus.mo
@@ -79,10 +85,12 @@ share/locale/ro/LC_MESSAGES/gnome-menus.mo
share/locale/ru/LC_MESSAGES/gnome-menus.mo
share/locale/rw/LC_MESSAGES/gnome-menus.mo
share/locale/sk/LC_MESSAGES/gnome-menus.mo
+share/locale/sl/LC_MESSAGES/gnome-menus.mo
share/locale/sq/LC_MESSAGES/gnome-menus.mo
share/locale/sr/LC_MESSAGES/gnome-menus.mo
share/locale/sr@Latn/LC_MESSAGES/gnome-menus.mo
share/locale/sv/LC_MESSAGES/gnome-menus.mo
+share/locale/ta/LC_MESSAGES/gnome-menus.mo
share/locale/te/LC_MESSAGES/gnome-menus.mo
share/locale/th/LC_MESSAGES/gnome-menus.mo
share/locale/tr/LC_MESSAGES/gnome-menus.mo
@@ -93,14 +101,44 @@ share/locale/xh/LC_MESSAGES/gnome-menus.mo
share/locale/zh_CN/LC_MESSAGES/gnome-menus.mo
share/locale/zh_HK/LC_MESSAGES/gnome-menus.mo
share/locale/zh_TW/LC_MESSAGES/gnome-menus.mo
+@dirrm share/gnome/desktop-directories
+@dirrm include/gnome-menus
+@dirrmtry etc/xdg/menus
+@dirrmtry etc/xdg
+@dirrmtry %%PYTHON_SITELIBDIR%%
+@dirrmtry %%PYTHON_LIBDIR%%
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
@dirrmtry share/locale/xh/LC_MESSAGES
@dirrmtry share/locale/xh
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
@dirrmtry share/locale/ug/LC_MESSAGES
@dirrmtry share/locale/ug
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/ro/LC_MESSAGES
+@dirrmtry share/locale/ro
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/nn/LC_MESSAGES
+@dirrmtry share/locale/nn
+@dirrmtry share/locale/ne/LC_MESSAGES
+@dirrmtry share/locale/ne
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
@dirrmtry share/locale/mg/LC_MESSAGES
@@ -109,15 +147,25 @@ share/locale/zh_TW/LC_MESSAGES/gnome-menus.mo
@dirrmtry share/locale/ky
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
@dirrmtry share/locale/hy/LC_MESSAGES
@dirrmtry share/locale/hy
+@dirrmtry share/locale/gn/LC_MESSAGES
+@dirrmtry share/locale/gn
+@dirrmtry share/locale/gl/LC_MESSAGES
+@dirrmtry share/locale/gl
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
-@dirrmtry share/locale/br/LC_MESSAGES
-@dirrmtry share/locale/br
-@dirrm share/gnome/desktop-directories
-@dirrm include/gnome-menus
-@dirrm etc/xdg/menus
-@dirrm etc/xdg
-@dirrmtry %%PYTHON_SITELIBDIR%%
-@dirrmtry %%PYTHON_LIBDIR%%
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be/LC_MESSAGES
+@dirrmtry share/locale/be