aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-session
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnome-session')
-rw-r--r--x11/gnome-session/Makefile14
-rw-r--r--x11/gnome-session/distinfo6
-rw-r--r--x11/gnome-session/files/patch-dbus72
-rw-r--r--x11/gnome-session/files/patch-gnome-session_gsm-at-startup.c10
-rw-r--r--x11/gnome-session/files/patch-gnome-session_gsm-xrandr.c10
-rw-r--r--x11/gnome-session/pkg-plist60
6 files changed, 107 insertions, 65 deletions
diff --git a/x11/gnome-session/Makefile b/x11/gnome-session/Makefile
index b15801e9298a..aa8578a569b5 100644
--- a/x11/gnome-session/Makefile
+++ b/x11/gnome-session/Makefile
@@ -3,16 +3,17 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnomesession/Makefile,v 1.83 2006/04/24 03:18:23 marcus Exp $
+# $MCom: ports/x11/gnome-session/Makefile,v 1.96 2006/10/07 19:45:39 marcus Exp $
#
PORTNAME= gnome-session
-PORTVERSION= 2.14.3
+PORTVERSION= 2.16.1
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME} \
${MASTER_SITE_LOCAL:S/$/:local/} \
http://people.FreeBSD.org/~adamw/images/gnome_splashes/2.12/:local
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/} \
+MASTER_SITE_SUBDIR= sources/gnome-session/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/} \
adamw/:local
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${SPLASHES}:local
@@ -22,9 +23,14 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Session component for the GNOME 2 desktop
+BUILD_DEPENDS= ${LOCALBASE}/libexec/gnome-settings-daemon:${PORTSDIR}/sysutils/gnome-control-center
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
+ gnome-keyring.0:${PORTSDIR}/security/gnome-keyring
+RUN_DEPENDS= ${LOCALBASE}/libexec/gnome-settings-daemon:${PORTSDIR}/sysutils/gnome-control-center
+
USE_GETTEXT= yes
USE_BZIP2= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop
GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
diff --git a/x11/gnome-session/distinfo b/x11/gnome-session/distinfo
index 3e94fa0eb81c..8b47213d8da0 100644
--- a/x11/gnome-session/distinfo
+++ b/x11/gnome-session/distinfo
@@ -1,6 +1,6 @@
-MD5 (gnome2/gnome-session-2.14.3.tar.bz2) = 34eb4641e2791ae51acf6f1edfcf3d64
-SHA256 (gnome2/gnome-session-2.14.3.tar.bz2) = 23dfb74225607c586eba3c0539cb5da0133f54b5b5f8407213893386643fa7b2
-SIZE (gnome2/gnome-session-2.14.3.tar.bz2) = 662903
+MD5 (gnome2/gnome-session-2.16.1.tar.bz2) = ef6f87cb3cc6012b212fa14353a63932
+SHA256 (gnome2/gnome-session-2.16.1.tar.bz2) = 6d6d21c6b9a4a2fe7bc288e8fdf36159444370973b4aa71dfc4c48bc0ad7cdf3
+SIZE (gnome2/gnome-session-2.16.1.tar.bz2) = 677501
MD5 (gnome2/freebsd-splashes-gnome-2.12.1.tar) = 4a098f0f2295c3333acff185d4bed5aa
SHA256 (gnome2/freebsd-splashes-gnome-2.12.1.tar) = c7008fc8f43cf07e3d84cbf0bd9b2846fa31aaf37d4f97993b185b4155f8ee27
SIZE (gnome2/freebsd-splashes-gnome-2.12.1.tar) = 1280000
diff --git a/x11/gnome-session/files/patch-dbus b/x11/gnome-session/files/patch-dbus
index edd18bfec916..e7982166670a 100644
--- a/x11/gnome-session/files/patch-dbus
+++ b/x11/gnome-session/files/patch-dbus
@@ -1,39 +1,3 @@
---- gnome-session/main.c.orig Tue Mar 21 12:37:40 2006
-+++ gnome-session/main.c Sun Apr 23 23:05:38 2006
-@@ -43,6 +43,7 @@
- #include "command.h"
- #include "splash-widget.h"
- #include "util.h"
-+#include "gsm-dbus.h"
- #include "gsm-sound.h"
- #include "gsm-gsd.h"
- #include "gsm-keyring.h"
-@@ -334,6 +335,7 @@ main (int argc, char *argv[])
- char *display_str;
- char **versions;
- GConfClient *gconf_client;
-+ gboolean dbus_daemon_owner;
-
- if (getenv ("GSM_VERBOSE_DEBUG"))
- gsm_set_verbose (TRUE);
-@@ -415,6 +417,7 @@ main (int argc, char *argv[])
- fprintf (stderr, "SESSION_MANAGER=%s\n", getenv ("SESSION_MANAGER"));
- gnome_window_icon_set_default_from_file (GNOME_ICONDIR"/gnome-session.png");
-
-+ dbus_daemon_owner = gsm_dbus_daemon_start ();
-
- /* Make sure children see the right value for DISPLAY. This is
- useful if --display was specified on the command line. */
-@@ -495,6 +498,9 @@ main (int argc, char *argv[])
- gsm_sound_logout ();
-
- gsm_keyring_daemon_stop ();
-+
-+ if (dbus_daemon_owner)
-+ gsm_dbus_daemon_stop ();
-
- g_object_unref (gconf_client);
- gsm_shutdown_gconfd ();
--- gnome-session/gsm-dbus.h.orig Sun Apr 23 23:01:47 2006
+++ gnome-session/gsm-dbus.h Sun Apr 23 23:00:53 2006
@@ -0,0 +1,27 @@
@@ -427,3 +391,39 @@
+ */
+ g_setenv ("DBUS_SESSION_BUS_ADDRESS", address_str, TRUE);
+}
+--- gnome-session/main.c.orig Wed Jul 26 08:46:36 2006
++++ gnome-session/main.c Mon Aug 7 21:17:49 2006
+@@ -43,6 +43,7 @@
+ #include "command.h"
+ #include "splash-widget.h"
+ #include "util.h"
++#include "gsm-dbus.h"
+ #include "gsm-sound.h"
+ #include "gsm-gsd.h"
+ #include "gsm-keyring.h"
+@@ -329,6 +330,7 @@
+ Session *the_session;
+ gboolean splashing;
+ gboolean a_t_support;
++ gboolean dbus_daemon_owner;
+ GError *err;
+ int status;
+ char *display_str;
+@@ -419,6 +421,7 @@
+ fprintf (stderr, "SESSION_MANAGER=%s\n", getenv ("SESSION_MANAGER"));
+ gnome_window_icon_set_default_from_file (GNOME_ICONDIR"/gnome-session.png");
+
++ dbus_daemon_owner = gsm_dbus_daemon_start ();
+
+ /* Make sure children see the right value for DISPLAY. This is
+ useful if --display was specified on the command line. */
+@@ -502,6 +505,9 @@
+ gsm_sound_logout ();
+
+ gsm_keyring_daemon_stop ();
++
++ if (dbus_daemon_owner)
++ gsm_dbus_daemon_stop ();
+
+ g_object_unref (gconf_client);
+ gsm_shutdown_gconfd ();
diff --git a/x11/gnome-session/files/patch-gnome-session_gsm-at-startup.c b/x11/gnome-session/files/patch-gnome-session_gsm-at-startup.c
deleted file mode 100644
index da4950d05c95..000000000000
--- a/x11/gnome-session/files/patch-gnome-session_gsm-at-startup.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- gnome-session/gsm-at-startup.c.orig Mon Apr 17 18:00:38 2006
-+++ gnome-session/gsm-at-startup.c Mon Apr 17 18:00:57 2006
-@@ -2,6 +2,7 @@
- #include <string.h>
-
- #include "gsm-at-startup.h"
-+#include "util.h"
-
- #include <gdk/gdk.h>
- #include <libgnome/libgnome.h>
diff --git a/x11/gnome-session/files/patch-gnome-session_gsm-xrandr.c b/x11/gnome-session/files/patch-gnome-session_gsm-xrandr.c
deleted file mode 100644
index 8eae88069c51..000000000000
--- a/x11/gnome-session/files/patch-gnome-session_gsm-xrandr.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- gnome-session/gsm-xrandr.c.orig Mon Apr 17 17:59:38 2006
-+++ gnome-session/gsm-xrandr.c Mon Apr 17 17:59:50 2006
-@@ -3,6 +3,7 @@
- #include <gconf/gconf-client.h>
-
- #include "gsm-xrandr.h"
-+#include "util.h"
-
- #ifdef HAVE_RANDR
- #include <stdio.h>
diff --git a/x11/gnome-session/pkg-plist b/x11/gnome-session/pkg-plist
index 89f7d32ff1f6..c34e0b2bf9ad 100644
--- a/x11/gnome-session/pkg-plist
+++ b/x11/gnome-session/pkg-plist
@@ -28,6 +28,7 @@ share/locale/az/LC_MESSAGES/gnome-session-2.0.mo
share/locale/be/LC_MESSAGES/gnome-session-2.0.mo
share/locale/bg/LC_MESSAGES/gnome-session-2.0.mo
share/locale/bn/LC_MESSAGES/gnome-session-2.0.mo
+share/locale/bn_IN/LC_MESSAGES/gnome-session-2.0.mo
share/locale/bs/LC_MESSAGES/gnome-session-2.0.mo
share/locale/ca/LC_MESSAGES/gnome-session-2.0.mo
share/locale/cs/LC_MESSAGES/gnome-session-2.0.mo
@@ -63,6 +64,7 @@ share/locale/ko/LC_MESSAGES/gnome-session-2.0.mo
share/locale/ku/LC_MESSAGES/gnome-session-2.0.mo
share/locale/lt/LC_MESSAGES/gnome-session-2.0.mo
share/locale/lv/LC_MESSAGES/gnome-session-2.0.mo
+share/locale/mg/LC_MESSAGES/gnome-session-2.0.mo
share/locale/mi/LC_MESSAGES/gnome-session-2.0.mo
share/locale/mk/LC_MESSAGES/gnome-session-2.0.mo
share/locale/ml/LC_MESSAGES/gnome-session-2.0.mo
@@ -73,15 +75,14 @@ share/locale/nb/LC_MESSAGES/gnome-session-2.0.mo
share/locale/ne/LC_MESSAGES/gnome-session-2.0.mo
share/locale/nl/LC_MESSAGES/gnome-session-2.0.mo
share/locale/nn/LC_MESSAGES/gnome-session-2.0.mo
-share/locale/no/LC_MESSAGES/gnome-session-2.0.mo
share/locale/nso/LC_MESSAGES/gnome-session-2.0.mo
+share/locale/or/LC_MESSAGES/gnome-session-2.0.mo
share/locale/pa/LC_MESSAGES/gnome-session-2.0.mo
share/locale/pl/LC_MESSAGES/gnome-session-2.0.mo
share/locale/pt/LC_MESSAGES/gnome-session-2.0.mo
share/locale/pt_BR/LC_MESSAGES/gnome-session-2.0.mo
share/locale/ro/LC_MESSAGES/gnome-session-2.0.mo
share/locale/ru/LC_MESSAGES/gnome-session-2.0.mo
-share/locale/rw/LC_MESSAGES/gnome-session-2.0.mo
share/locale/sk/LC_MESSAGES/gnome-session-2.0.mo
share/locale/sl/LC_MESSAGES/gnome-session-2.0.mo
share/locale/sq/LC_MESSAGES/gnome-session-2.0.mo
@@ -93,6 +94,7 @@ share/locale/th/LC_MESSAGES/gnome-session-2.0.mo
share/locale/tk/LC_MESSAGES/gnome-session-2.0.mo
share/locale/tr/LC_MESSAGES/gnome-session-2.0.mo
share/locale/uk/LC_MESSAGES/gnome-session-2.0.mo
+share/locale/rw/LC_MESSAGES/gnome-session-2.0.mo
share/locale/vi/LC_MESSAGES/gnome-session-2.0.mo
share/locale/wa/LC_MESSAGES/gnome-session-2.0.mo
share/locale/xh/LC_MESSAGES/gnome-session-2.0.mo
@@ -100,11 +102,65 @@ share/locale/zh_CN/LC_MESSAGES/gnome-session-2.0.mo
share/locale/zh_HK/LC_MESSAGES/gnome-session-2.0.mo
share/locale/zh_TW/LC_MESSAGES/gnome-session-2.0.mo
share/locale/zu/LC_MESSAGES/gnome-session-2.0.mo
+@dirrmtry share/locale/zu/LC_MESSAGES
+@dirrmtry share/locale/zu
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/tk/LC_MESSAGES
+@dirrmtry share/locale/tk
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/ro/LC_MESSAGES
+@dirrmtry share/locale/ro
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/nso/LC_MESSAGES
+@dirrmtry share/locale/nso
+@dirrmtry share/locale/nn/LC_MESSAGES
+@dirrmtry share/locale/nn
+@dirrmtry share/locale/ne/LC_MESSAGES
+@dirrmtry share/locale/ne
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mi/LC_MESSAGES
+@dirrmtry share/locale/mi
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
@dirrmtry share/locale/hy/LC_MESSAGES
@dirrmtry share/locale/hy
+@dirrmtry share/locale/gl/LC_MESSAGES
+@dirrmtry share/locale/gl
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be/LC_MESSAGES
+@dirrmtry share/locale/be