aboutsummaryrefslogtreecommitdiff
path: root/x11/gnomeapplets2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnomeapplets2/Makefile')
-rw-r--r--x11/gnomeapplets2/Makefile28
1 files changed, 24 insertions, 4 deletions
diff --git a/x11/gnomeapplets2/Makefile b/x11/gnomeapplets2/Makefile
index 28b69fcfec0c..4d86584d6f0b 100644
--- a/x11/gnomeapplets2/Makefile
+++ b/x11/gnomeapplets2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gnomeapplets2
-PORTVERSION= 2.6.2.1
-PORTREVISION= 4
+PORTVERSION= 2.8.1.1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-applets/2.6
+MASTER_SITE_SUBDIR= sources/gnome-applets/2.8
DISTNAME= gnome-applets-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -29,7 +28,15 @@ USE_GNOME= gnomehier gnomeprefix gnomehack intlhack gnomepanel \
gstreamerplugins gail
USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ FREEBSD_SYS=${FREEBSD_SYS}
+
+GCONF_SCHEMAS= charpick.schemas drivemount.schemas geyes.schemas gkb.schemas \
+ gswitchit.schemas gtik.schemas gweather.schemas \
+ mailcheck.schemas mini-commander.schemas mixer.schemas \
+ modemlights.schemas multiload.schemas stickynotes.schemas
+
+FREEBSD_SYS?= /usr/src/sys
.include <bsd.port.pre.mk>
@@ -37,7 +44,20 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -fPIC"
PLIST_SUB= BATTERY="@comment "
.else
+GCONF_SCHEMAS+= battstat.schemas
PLIST_SUB= BATTERY=""
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " W A R N I N G"
+ @${ECHO_MSG} "*****************************************************"
+ @${ECHO_MSG} "* gnomeapplets2 requires that you have your kernel *"
+ @${ECHO_MSG} "* sources installed. If your kernel sources *"
+ @${ECHO_MSG} "* are somewhere other than /usr/src/sys, you *"
+ @${ECHO_MSG} "* may set the FREEBSD_SYS variable to the *"
+ @${ECHO_MSG} "* correct path. *"
+ @${ECHO_MSG} "*****************************************************"
+ @${ECHO_MSG} ""
.endif
.include <bsd.port.post.mk>