aboutsummaryrefslogtreecommitdiff
path: root/x11/kdebase4-runtime/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11/kdebase4-runtime/files')
-rw-r--r--x11/kdebase4-runtime/files/patch-client.c79
-rw-r--r--x11/kdebase4-runtime/files/patch-dm.c19
-rw-r--r--x11/kdebase4-runtime/files/patch-dm.h12
-rw-r--r--x11/kdebase4-runtime/files/patch-error.c60
-rw-r--r--x11/kdebase4-runtime/files/patch-kdm-backend-Makefile.am12
-rw-r--r--x11/kdebase4-runtime/files/patch-kdm-backend-netaddr.c33
-rw-r--r--x11/kdebase4-runtime/files/patch-kdm-backend-printf.c126
-rw-r--r--x11/kdebase4-runtime/files/patch-kdm-backend-protodpy.c22
-rw-r--r--x11/kdebase4-runtime/files/patch-kdm-backend-xdmcp.c23
-rw-r--r--x11/kdebase4-runtime/files/patch-kdm-configure.in.in20
-rw-r--r--x11/kdebase4-runtime/files/patch-kdm-kfrontend-genkdmconf.c111
11 files changed, 18 insertions, 499 deletions
diff --git a/x11/kdebase4-runtime/files/patch-client.c b/x11/kdebase4-runtime/files/patch-client.c
deleted file mode 100644
index 6c54790a82de..000000000000
--- a/x11/kdebase4-runtime/files/patch-client.c
+++ /dev/null
@@ -1,79 +0,0 @@
---- ./kdm/backend/client.c.orig Sun Mar 24 12:31:09 2002
-+++ ./kdm/backend/client.c Thu Apr 18 20:53:44 2002
-@@ -52,6 +52,12 @@
- #ifdef K5AUTH
- # include <krb5/krb5.h>
- #endif
-+#ifdef CSRG_BASED
-+# ifdef HAS_SETUSERCONTEXT
-+# include <login_cap.h>
-+# define USE_LOGIN_CAP 1
-+# endif
-+#endif
- #ifdef USE_PAM
- # include <security/pam_appl.h>
- #elif defined(AIXV3) /* USE_PAM */
-@@ -71,13 +77,6 @@
- # include <kafs.h>
- # endif
- # endif
--# ifdef CSRG_BASED
--# include <sys/param.h>
--# ifdef HAS_SETUSERCONTEXT
--# include <login_cap.h>
--# define USE_LOGIN_CAP 1
--# endif
--# endif
- /* for nologin */
- # include <sys/types.h>
- # include <unistd.h>
-@@ -867,12 +866,11 @@
- char *msg;
- char **theenv;
- extern char **newenv; /* from libs.a, this is set up by setpenv */
--# else
--# ifdef HAS_SETUSERCONTEXT
-- extern char **environ;
--# endif
- # endif
- #endif
-+#ifdef HAS_SETUSERCONTEXT
-+ extern char **environ;
-+#endif
- char *failsafeArgv[2];
- struct verify_info *verify;
- int i, pid;
-@@ -1004,10 +1002,11 @@
-
- #ifndef AIXV3
-
--# if !defined(HAS_SETUSERCONTEXT) || defined(USE_PAM)
-+# ifndef HAS_SETUSERCONTEXT
- if (!SetGid (name, verify->gid))
- exit (1);
--# ifdef USE_PAM
-+# endif
-+# ifdef USE_PAM
- pam_setcred(pamh, 0);
- /* pass in environment variables set by libpam and modules it called */
- pam_env = pam_getenvlist(pamh);
-@@ -1015,7 +1014,8 @@
- if (pam_env)
- for(; *pam_env; pam_env++)
- verify->userEnviron = putEnv(*pam_env, verify->userEnviron);
--# endif
-+# endif
-+# ifndef HAS_SETUSERCONTEXT
- # if defined(BSD) && (BSD >= 199103)
- if (setlogin(name) < 0)
- {
-@@ -1025,7 +1025,8 @@
- # endif
- if (!SetUid (name, verify->uid))
- exit (1);
--# else /* HAS_SETUSERCONTEXT && !USE_PAM */
-+# else /* HAS_SETUSERCONTEXT */
-+
- /*
- * Destroy environment unless user has requested its preservation.
- * We need to do this before setusercontext() because that may
diff --git a/x11/kdebase4-runtime/files/patch-dm.c b/x11/kdebase4-runtime/files/patch-dm.c
deleted file mode 100644
index 3004d8e5f91a..000000000000
--- a/x11/kdebase4-runtime/files/patch-dm.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- ./kdm/backend/dm.c.orig Sun Mar 24 12:31:09 2002
-+++ ./kdm/backend/dm.c Thu Apr 18 20:53:44 2002
-@@ -236,7 +236,6 @@
- else
- break;
- }
-- InitErrorLog (errorLogFile);
-
- /*
- * Only allow root to run in non-debug mode to avoid problems
-@@ -246,6 +245,8 @@
- fprintf (stderr, "Only root wants to run %s\n", prog);
- exit (1);
- }
-+
-+ InitErrorLog (errorLogFile);
-
- /*
- * Step 1 - load configuration parameters
diff --git a/x11/kdebase4-runtime/files/patch-dm.h b/x11/kdebase4-runtime/files/patch-dm.h
deleted file mode 100644
index f9f540e3486c..000000000000
--- a/x11/kdebase4-runtime/files/patch-dm.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./kdm/backend/dm.h.orig Sun Mar 24 12:31:09 2002
-+++ ./kdm/backend/dm.h Thu Apr 18 20:53:44 2002
-@@ -72,6 +72,9 @@
- # include <X11/Xdmcp.h>
- #endif
-
-+#ifdef CSRG_BASED
-+# include <sys/param.h>
-+#endif
- #ifdef pegasus
- # undef dirty /* Some bozo put a macro called dirty in sys/param.h */
- #endif
diff --git a/x11/kdebase4-runtime/files/patch-error.c b/x11/kdebase4-runtime/files/patch-error.c
deleted file mode 100644
index 4d2ace7334f8..000000000000
--- a/x11/kdebase4-runtime/files/patch-error.c
+++ /dev/null
@@ -1,60 +0,0 @@
---- ./kdm/backend/error.c.orig Sun Mar 24 12:31:09 2002
-+++ ./kdm/backend/error.c Thu Apr 18 20:53:44 2002
-@@ -43,6 +43,8 @@
- #include "dm.h"
- #include "dm_error.h"
-
-+#include <sys/stat.h>
-+#include <unistd.h>
- #include <stdio.h>
-
- #define PRINT_QUOTES
-@@ -91,6 +93,10 @@
- void
- InitErrorLog (const char *errorLogFile)
- {
-+ int fd;
-+ struct stat st;
-+ char buf[128];
-+
- #ifdef USE_SYSLOG
- # ifdef USE_PAM
- ReInitErrorLog ();
-@@ -101,15 +107,33 @@
- /* We do this independently of using syslog, as we cannot redirect
- * the output of external programs to syslog.
- */
-- if (isatty (2)) {
-- char buf[100];
-+ if (errorLogFile
-+ || fstat (1, &st) ||
-+#ifndef X_NOT_POSIX
-+ !(S_ISREG(st.st_mode) || S_ISFIFO(st.st_mode))
-+#else
-+ !(st.st_mode & (S_IFREG | S_IFIFO))
-+#endif
-+ || fstat (2, &st) ||
-+#ifndef X_NOT_POSIX
-+ !(S_ISREG(st.st_mode) || S_ISFIFO(st.st_mode)))
-+#else
-+ !(st.st_mode & (S_IFREG | S_IFIFO)))
-+#endif
-+ {
- if (!errorLogFile) {
- sprintf (buf, "/var/log/%s.log", prog);
- errorLogFile = buf;
- }
-- if (!freopen (errorLogFile, "a", stderr))
-+ if ((fd = open (errorLogFile, O_CREAT | O_APPEND | O_WRONLY, 0666)) < 0)
- LogError ("Cannot open log file %s\n", errorLogFile);
-+ else {
-+ if (fd != 1) {
-+ dup2 (fd, 1);
-+ close (fd);
-+ }
-+ dup2 (1, 2);
-+ }
- }
-- dup2 (2, 1);
- }
-
diff --git a/x11/kdebase4-runtime/files/patch-kdm-backend-Makefile.am b/x11/kdebase4-runtime/files/patch-kdm-backend-Makefile.am
deleted file mode 100644
index cf370f25d126..000000000000
--- a/x11/kdebase4-runtime/files/patch-kdm-backend-Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./kdm/backend/Makefile.am.orig Sun Sep 23 09:29:27 2001
-+++ ./kdm/backend/Makefile.am Thu Apr 18 20:53:44 2002
-@@ -1,6 +1,7 @@
--INCLUDES = $(all_includes) $(KERBEROS_INCS)
-+INCLUDES = $(X_INCLUDES) $(USER_INCLUDES) $(KERBEROS_INCS)
-+CPPFLAGS =
- AM_CFLAGS = $(XDM_CFLAGS)
--LDFLAGS = $(all_libraries) $(KDE_RPATH) $(KRB_RPATH)
-+LDFLAGS = $(X_LDFLAGS) $(USER_LDFLAGS) $(KDE_RPATH) $(KRB_RPATH)
- LDADD = $(LIB_X11) -lXau $(LIBXDMCP) $(PASSWDLIBS) \
- $(LIB_LIBS) $(KERBEROS_LIBS) $(LIBSOCKET) $(LIBRESOLV) \
- $(LIBUCB) $(LIBUTIL)
diff --git a/x11/kdebase4-runtime/files/patch-kdm-backend-netaddr.c b/x11/kdebase4-runtime/files/patch-kdm-backend-netaddr.c
deleted file mode 100644
index c0b18f485e00..000000000000
--- a/x11/kdebase4-runtime/files/patch-kdm-backend-netaddr.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- ./kdm/backend/netaddr.c.orig Sun Mar 24 12:31:09 2002
-+++ ./kdm/backend/netaddr.c Thu Apr 18 20:53:44 2002
-@@ -216,11 +216,10 @@
- #ifdef DEBUG
- /*ARGSUSED*/
- void
--PrintSockAddr (struct sockaddr *a, int len)
-+PrintSockAddr (char *buf, struct sockaddr *a, int len)
- {
- unsigned char *t, *p;
-
-- Debug ("family %d, ", a->sa_family);
- switch (a->sa_family) {
- #ifdef AF_INET
- case AF_INET:
-@@ -228,11 +227,14 @@
- p = (unsigned char *) &((struct sockaddr_in *) a)->sin_port;
- t = (unsigned char *) &((struct sockaddr_in *) a)->sin_addr;
-
-- Debug ("port %d, host %d.%d.%d.%d\n",
-- (p[0] << 8) + p[1], t[0], t[1], t[2], t[3]);
-+ sprintf (buf, "family AF_INET, port %d, host %d.%d.%d.%d",
-+ (p[0] << 8) + p[1], t[0], t[1], t[2], t[3]);
- break;
-- }
- #endif
-+ default:
-+ sprintf (buf, "unknown family %d", a->sa_family);
-+ break;
-+ }
- }
- #endif
-
diff --git a/x11/kdebase4-runtime/files/patch-kdm-backend-printf.c b/x11/kdebase4-runtime/files/patch-kdm-backend-printf.c
deleted file mode 100644
index 79033f3d7af3..000000000000
--- a/x11/kdebase4-runtime/files/patch-kdm-backend-printf.c
+++ /dev/null
@@ -1,126 +0,0 @@
---- ./kdm/backend/printf.c.orig Sun Mar 24 12:31:09 2002
-+++ ./kdm/backend/printf.c Thu Apr 18 20:53:44 2002
-@@ -65,7 +65,7 @@
- */
-
- /**************************************************************
-- * (C) 2001 Oswald Buddenhagen <ossi@kde.org>
-+ * (C) 2001-2002 Oswald Buddenhagen <ossi@kde.org>
- * Partially stolen from OpenSSH's OpenBSD compat directory.
- * (C) Patrick Powell, Brandon Long, Thomas Roessler,
- * Michael Elkins, Ben Lindstrom
-@@ -507,23 +507,24 @@
- #ifdef USE_SYSLOG
- syslog (LOG_CRIT, "Out of memory in %s()", fkt);
- #else
-- char dbuf[20];
-+ int el;
-+ char dbuf[24], sbuf[128];
- logTime (dbuf);
-- fprintf (stderr, "%s "
-+ el = sprintf (sbuf, "%s "
- # ifdef LOG_NAME
- LOG_NAME "[%ld]: Out of memory in %s()\n", dbuf,
- # else
- "%s[%ld]: Out of memory in %s()\n", dbuf, prog,
- # endif
- (long)getpid(), fkt);
-- fflush (stderr);
-+ write (2, sbuf, el);
- #endif
- }
-
- typedef struct {
- char *buf;
- int clen, blen, type;
-- char lmbuf[100];
-+ char lmbuf[128];
- } OCLBuf;
-
- static void
-@@ -533,25 +534,11 @@
- #ifdef USE_SYSLOG
- syslog (lognums[oclbp->type], "%.*s", oclbp->clen, oclbp->buf);
- #else
-- char dbuf[20];
-- logTime (dbuf);
-- fprintf (stderr, "%s "
--# ifdef LOG_NAME
-- LOG_NAME "[%ld] %s: %.*s\n", dbuf,
--# else
-- "%s[%ld] %s: %.*s\n", dbuf, prog,
--# endif
-- (long)getpid(), lognams[oclbp->type], oclbp->clen, oclbp->buf);
-- fflush (stderr);
-+ oclbp->buf[oclbp->clen] = '\n';
-+ write (2, oclbp->buf, oclbp->clen + 1);
- #endif
- oclbp->clen = 0;
- }
-- if (oclbp->buf) {
-- if (oclbp->buf != oclbp->lmbuf)
-- free (oclbp->buf);
-- oclbp->buf = 0;
-- oclbp->blen = 0;
-- }
- }
-
- static void
-@@ -564,10 +551,17 @@
- if (c == '\n')
- OutChLFlush (oclbp);
- else {
-+#ifndef USE_SYSLOG
-+ if (oclbp->clen >= oclbp->blen - 1) {
-+#else
- if (oclbp->clen >= oclbp->blen) {
-- if (oclbp->buf == oclbp->lmbuf)
-+#endif
-+ if (oclbp->buf == oclbp->lmbuf) {
- OutChLFlush (oclbp);
-- nlen = oclbp->blen * 3 / 2 + 100;
-+ oclbp->buf = 0;
-+ oclbp->blen = 0;
-+ }
-+ nlen = oclbp->blen * 3 / 2 + 128;
- nbuf = realloc (oclbp->buf, nlen);
- if (nbuf) {
- oclbp->buf = nbuf;
-@@ -579,6 +573,19 @@
- oclbp->blen = sizeof(oclbp->lmbuf);
- }
- }
-+#ifndef USE_SYSLOG
-+ if (!oclbp->clen) {
-+ char dbuf[24];
-+ logTime (dbuf);
-+ oclbp->clen = sprintf (oclbp->buf, "%s "
-+# ifdef LOG_NAME
-+ LOG_NAME "[%ld] %s: ", dbuf,
-+# else
-+ "%s[%ld] %s: ", dbuf, prog,
-+# endif
-+ (long)getpid(), lognams[oclbp->type]);
-+ }
-+#endif
- oclbp->buf[oclbp->clen++] = c;
- }
- }
-@@ -586,13 +593,12 @@
- static void
- Logger (int type, const char *fmt, va_list args)
- {
-- static OCLBuf oclb;
-+ OCLBuf oclb = { 0, 0, 0, type };
-
-- if (oclb.type != type) {
-- OutChLFlush (&oclb);
-- oclb.type = type;
-- }
- DoPr(OutChL, &oclb, fmt, args);
-+ /* no flush, every message is supposed to be \n-terminated */
-+ if (oclb.buf && oclb.buf != oclb.lmbuf)
-+ free (oclb.buf);
- }
-
- #ifdef LOG_DEBUG_MASK
diff --git a/x11/kdebase4-runtime/files/patch-kdm-backend-protodpy.c b/x11/kdebase4-runtime/files/patch-kdm-backend-protodpy.c
deleted file mode 100644
index 0dee6a5c520d..000000000000
--- a/x11/kdebase4-runtime/files/patch-kdm-backend-protodpy.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./kdm/backend/protodpy.c.orig Sun Mar 24 12:31:09 2002
-+++ ./kdm/backend/protodpy.c Thu Apr 18 20:53:44 2002
-@@ -48,12 +48,13 @@
- PrintProtoDisplay (pdpy)
- struct protoDisplay *pdpy;
- {
-- Debug ("ProtoDisplay %p\n", pdpy);
-- Debug ("\taddress: ");
-- PrintSockAddr (pdpy->address, pdpy->addrlen);
-- Debug ("\tdate %d (%d from now)\n", pdpy->date, time(0) - pdpy->date);
-- Debug ("\tdisplay Number %d\n", pdpy->displayNumber);
-- Debug ("\tsessionID %d\n", pdpy->sessionID);
-+ char addrbuf[128];
-+
-+ PrintSockAddr (addrbuf, pdpy->address, pdpy->addrlen);
-+ Debug ("ProtoDisplay %p\n\taddress: %s\n\tdate %d (%d from now)\n"
-+ "\tdisplay Number %d\n\tsessionID %d\n",
-+ pdpy, addrbuf, pdpy->date, time(0) - pdpy->date,
-+ pdpy->displayNumber, pdpy->sessionID);
- }
- #endif
-
diff --git a/x11/kdebase4-runtime/files/patch-kdm-backend-xdmcp.c b/x11/kdebase4-runtime/files/patch-kdm-backend-xdmcp.c
index ab365e01bd60..51b037275a59 100644
--- a/x11/kdebase4-runtime/files/patch-kdm-backend-xdmcp.c
+++ b/x11/kdebase4-runtime/files/patch-kdm-backend-xdmcp.c
@@ -1,24 +1,11 @@
---- ./kdm/backend/xdmcp.c.orig Sun Mar 24 12:31:09 2002
-+++ ./kdm/backend/xdmcp.c Thu Apr 18 20:53:44 2002
-@@ -510,10 +510,8 @@
- j = 0;
- for (i = 0; i < (int)clientPort.length; i++)
- j = j * 256 + clientPort.data[i];
-- Debug ("Forward client address (port %d)", j);
-- for (i = 0; i < (int)clientAddress.length; i++)
-- Debug (" %d", clientAddress.data[i]);
-- Debug ("\n");
-+ Debug ("Forward client address (port %d) %[*hhu\n", j,
-+ clientAddress.length, clientAddress.data);
- switch (from->sa_family)
- {
- #ifdef AF_INET
-@@ -1014,7 +1012,7 @@
+++--- kdm/backend/xdmcp.c.orig Sun May 19 10:38:01 2002
++++++ kdm/backend/xdmcp.c Sun May 19 10:38:16 2002
+++@@ -1012,7 +1012,7 @@
sprintf (buf, "Session %ld failed for display %.260s: %s",
(long) sessionID, name, reason);
-- Debug ("send_failed(\"%s\")", buf);
-+ Debug ("send_failed(%\"s)\n", buf);
+- Debug ("send_failed(%\"s)", buf);
++ Debug ("send_failed(%s)\n", buf);
status.length = strlen (buf);
status.data = (CARD8Ptr) buf;
header.version = XDM_PROTOCOL_VERSION;
diff --git a/x11/kdebase4-runtime/files/patch-kdm-configure.in.in b/x11/kdebase4-runtime/files/patch-kdm-configure.in.in
deleted file mode 100644
index 2523cd5e64d3..000000000000
--- a/x11/kdebase4-runtime/files/patch-kdm-configure.in.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./kdm/configure.in.in.orig Sun Mar 24 12:31:09 2002
-+++ ./kdm/configure.in.in Thu Apr 18 20:53:44 2002
-@@ -220,8 +220,6 @@
- [ AC_MSG_ERROR([--with-rpcauth requires Sun RPC header files.])])
- fi
-
--if test "x$use_pam" = xno; then
--
- dnl should be:
- dnl AC_CHECK_MEMBER(struct passwd.pw_expire, [ XDM_CFLAGS="$XDM_CFLAGS -DHAVE_PW_EXPIRE" ], , [#include <pwd.h>])
- dnl but somehow it doesn't work. so we make it by hand ...
-@@ -245,8 +243,6 @@
- AC_CHECK_FUNC(login_getclass, [ XDM_CFLAGS="$XDM_CFLAGS -DHAVE_LOGIN_GETCLASS" ])
- AC_CHECK_FUNC(auth_timeok, [ XDM_CFLAGS="$XDM_CFLAGS -DHAVE_AUTH_TIMEOK" ])
- LIBS=$ac_save_libs
--
--fi
-
- AC_CHECK_FUNC(vsyslog, [ XDM_CFLAGS="$XDM_CFLAGS -DUSE_SYSLOG" ])
- if test "x$use_pam" = xyes; then
diff --git a/x11/kdebase4-runtime/files/patch-kdm-kfrontend-genkdmconf.c b/x11/kdebase4-runtime/files/patch-kdm-kfrontend-genkdmconf.c
index 5f6252b5266c..616f0f71e3ef 100644
--- a/x11/kdebase4-runtime/files/patch-kdm-kfrontend-genkdmconf.c
+++ b/x11/kdebase4-runtime/files/patch-kdm-kfrontend-genkdmconf.c
@@ -1,107 +1,22 @@
---- ./kdm/kfrontend/genkdmconf.c.orig Thu Mar 21 21:11:30 2002
-+++ ./kdm/kfrontend/genkdmconf.c Thu Apr 18 21:22:40 2002
-@@ -37,6 +37,10 @@
- #include <ctype.h>
- #include <stdarg.h>
- #include <fcntl.h>
-+#include <sys/param.h>
-+#ifdef BSD
-+# include <utmp.h>
-+#endif
-
- #if __GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ > 4)
- # define ATTR_UNUSED __attribute__((unused))
-@@ -358,11 +362,11 @@
-
- const char def_willing[] =
- "#! /bin/sh\n"
--"# The output of this script is displayed in the chooser window.\n"
--"# (instead of \"Willing to manage\")\n"
-+"# The output of this script is displayed in the chooser window\n"
-+"# (instead of \"Willing to manage\").\n"
- "\n"
--"load=\"`uptime|sed -e 's/^.*load[^0-9]*//'`\"\n"
--"nrusers=\"`who|cut -c 1-8|sort -u|wc -l|sed 's/^[ ]*//'`\"\n"
-+"load=`uptime|sed -e 's/^.*load[^0-9]*//'`\n"
-+"nrusers=`who|cut -c 1-8|sort -u|wc -l|sed 's/^[ ]*//'`\n"
- "s=\"\"; [ \"$nrusers\" != 1 ] && s=s\n"
- "\n"
- "echo \"${nrusers} user${s}, load: ${load}\"\n";
-@@ -377,7 +381,10 @@
- " echo $! >$PIDFILE\n"
- " wait $!\n"
- " rm $PIDFILE\n"
--") &\n";
-+") &\n"
-+"\n"
-+"#xconsole -geometry 480x130-0-0 -notify -verbose -fn fixed -exitOnFail -file /dev/xconsole &\n"
-+"\n";
-
- const char def_startup[] =
- "#! /bin/sh\n"
-@@ -391,14 +398,11 @@
- "# By convention, both xconsole and xterm -C check that the\n"
- "# console is owned by the invoking user and is readable before attaching\n"
- "# the console output. This way a random user can invoke xterm -C without\n"
--"# causing serious grief.\n"
--"# This is not required if you use PAM, as pam_console should handle it.\n"
-+"# causing serious grief; still, it can cause havoc, so xconsole is started\n"
-+"# by Xsetup usually.\n"
-+"# This is not required if you use PAM with the pam_console module.\n"
+--- kdm/kfrontend/genkdmconf.c.orig Wed May 8 14:21:31 2002
++++ kdm/kfrontend/genkdmconf.c Sat May 25 13:19:06 2002
+@@ -402,7 +402,7 @@
+ "# by Xsetup usually.\n"
+ "# This is not required if you use PAM with the pam_console module.\n"
"#\n"
--#ifdef HAVE_PAM
- "#chown $USER /dev/console\n"
--#else
--"chown $USER /dev/console\n"
--#endif
+-"#chown $USER /dev/console\n"
++"chown $USER /dev/console\n"
"\n"
#ifdef _AIX
"# We create a pseudodevice for finger. (host:0 becomes kdm/host_0)\n"
-@@ -425,11 +429,11 @@
- " fi\n"
- "fi\n";
- #else
--"#exec sessreg -a -l $DISPLAY "
-+"exec sessreg -a -l $DISPLAY"
- # ifdef BSD
--"-x " KDMCONF "/Xservers "
-+" -x " KDMCONF "/Xservers -u " _PATH_UTMP
- # endif
--"$USER\n";
-+" $USER\n";
- #endif /* _AIX */
-
- const char def_reset[] =
-@@ -437,16 +441,10 @@
- "# Xreset - run as root after session exits\n"
- "\n"
+@@ -443,8 +443,8 @@
"# Reassign ownership of the console to root, this should disallow\n"
--"# assignment of console output to any random users's xterm\n"
--"# This is not required if you use PAM, as pam_console should handle it.\n"
-+"# assignment of console output to any random users's xterm. See Xstartup.\n"
+ "# assignment of console output to any random users's xterm. See Xstartup.\n"
"#\n"
--#ifdef HAVE_PAM
- "#chown root /dev/console\n"
- "#chmod 622 /dev/console\n"
--#else
--"chown root /dev/console\n"
--"chmod 622 /dev/console\n"
--#endif
+-"#chown root /dev/console\n"
+-"#chmod 622 /dev/console\n"
++"chown root /dev/console\n"
++/* "#chmod 622 /dev/console\n" */
"\n"
#ifdef _AIX
"if [ -f /usr/lib/X11/xdm/sessreg ]; then\n"
-@@ -454,11 +452,11 @@
- " exec /usr/lib/X11/xdm/sessreg -d -l xdm/$devname $USER\n"
- "fi\n";
- #else
--"#exec sessreg -d -l $DISPLAY "
-+"exec sessreg -d -l $DISPLAY"
- # ifdef BSD
--"-x " KDMCONF "/Xservers "
-+" -x " KDMCONF "/Xservers -u " _PATH_UTMP
- # endif
--"$USER\n";
-+" $USER\n";
- #endif /* _AIX */
-
- const char def_session[] =