aboutsummaryrefslogtreecommitdiff
path: root/x11/kdebase4/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11/kdebase4/files')
-rw-r--r--x11/kdebase4/files/patch-kdm::kfrontend::Makefile.am15
-rw-r--r--x11/kdebase4/files/patch-kdm::kfrontend::genkdmconf.c13
-rw-r--r--x11/kdebase4/files/patch-ksysguardd.c22
3 files changed, 35 insertions, 15 deletions
diff --git a/x11/kdebase4/files/patch-kdm::kfrontend::Makefile.am b/x11/kdebase4/files/patch-kdm::kfrontend::Makefile.am
new file mode 100644
index 000000000000..c5274c1096ac
--- /dev/null
+++ b/x11/kdebase4/files/patch-kdm::kfrontend::Makefile.am
@@ -0,0 +1,15 @@
+--- kdm/kfrontend/Makefile.am.~1.21.~ Sun Jul 29 00:56:28 2001
++++ kdm/kfrontend/Makefile.am Mon Dec 10 01:08:15 2001
+@@ -25,10 +25,8 @@
+ genkdmconf_LDADD = $(LIB_X11)
+
+ install-data-local:
+- @if test ! -d $(DESTDIR)$(kde_confdir)/kdm; then \
+- $(mkinstalldirs) $(DESTDIR)$(kde_confdir)/kdm; \
+- ./genkdmconf --in $(DESTDIR)$(kde_confdir)/kdm; \
+- fi
++ -$(mkinstalldirs) $(DESTDIR)$(kde_confdir)/kdm
++ ./genkdmconf --no-old --in $(DESTDIR)$(kde_confdir)/kdm
+
+ messages:
+ $(XGETTEXT) $(kdm_greet_SOURCES) -o $(podir)/kdmgreet.pot
diff --git a/x11/kdebase4/files/patch-kdm::kfrontend::genkdmconf.c b/x11/kdebase4/files/patch-kdm::kfrontend::genkdmconf.c
index 84fdeaf99ba2..6aeac3d4433e 100644
--- a/x11/kdebase4/files/patch-kdm::kfrontend::genkdmconf.c
+++ b/x11/kdebase4/files/patch-kdm::kfrontend::genkdmconf.c
@@ -1,5 +1,5 @@
---- kdm/kfrontend/genkdmconf.c.orig Wed Sep 5 08:15:47 2001
-+++ kdm/kfrontend/genkdmconf.c Tue Oct 23 04:04:22 2001
+--- kdm/kfrontend/genkdmconf.c.orig Mon Nov 5 21:40:03 2001
++++ kdm/kfrontend/genkdmconf.c Sun Dec 9 22:42:26 2001
@@ -212,7 +212,7 @@
*/
@@ -27,3 +27,12 @@
"-x " KDMCONF "/Xservers "
#endif
"$USER\n"
+@@ -1781,7 +1781,7 @@
+ }
+ addKdePath ("UserPath", DEF_USER_PATH);
+ addKdePath ("SystemPath", DEF_SYSTEM_PATH);
+- ASPrintf (&newkdmrc, "%s/kdmrc", newdir);
++ ASPrintf (&newkdmrc, "%s/kdmrc.dist", newdir);
+ f = Create (newkdmrc, kdmrcmode);
+ wrconf (f);
+ fclose (f);
diff --git a/x11/kdebase4/files/patch-ksysguardd.c b/x11/kdebase4/files/patch-ksysguardd.c
index 940aa4d327a5..e7a37616b367 100644
--- a/x11/kdebase4/files/patch-ksysguardd.c
+++ b/x11/kdebase4/files/patch-ksysguardd.c
@@ -1,15 +1,11 @@
---- ksysguard/ksysguardd/FreeBSD/ksysguardd.c 2001/11/17 02:01:46 1.5
-+++ ksysguard/ksysguardd/FreeBSD/ksysguardd.c 2001/11/17 06:16:15 1.6
-@@ -17,9 +17,11 @@
- along with this program; if not, write to the Free Software
- Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+--- ksysguard/ksysguardd/FreeBSD/ksysguardd.c.orig Sat Nov 10 00:17:04 2001
++++ ksysguard/ksysguardd/FreeBSD/ksysguardd.c Sun Dec 9 22:26:48 2001
+@@ -37,6 +37,8 @@
+ #include <sys/wait.h>
+ #include <unistd.h>
-- $Id: ksysguardd.c,v 1.2.6.1 2001/11/08 10:48:51 tokoe Exp $
-+ $Id: ksysguardd.c,v 1.6 2001/11/17 06:16:15 waba Exp $
- */
-
-+#include <config.h>
++#include "config.h"
+
- #include <ctype.h>
- #include <fcntl.h>
- #include <netdb.h>
+ #include "CPU.h"
+ #include "Command.h"
+ #include "Memory.h"