aboutsummaryrefslogtreecommitdiff
path: root/x11/kitty/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/kitty/Makefile')
-rw-r--r--x11/kitty/Makefile25
1 files changed, 17 insertions, 8 deletions
diff --git a/x11/kitty/Makefile b/x11/kitty/Makefile
index 88118c0bbe89..13b8eb83bcc7 100644
--- a/x11/kitty/Makefile
+++ b/x11/kitty/Makefile
@@ -1,7 +1,8 @@
PORTNAME= kitty
-DISTVERSION= 0.25.0
+DISTVERSION= 0.25.2
+PORTREVISION= 1
CATEGORIES= x11 wayland
-MASTER_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/releases/download/v${DISTVERSION}/
+MASTER_SITES= https://github.com/kovidgoyal/${PORTNAME}/releases/download/v${DISTVERSION}/
MAINTAINER= alexis.praga@free.fr
COMMENT= Cross-platform, fast, featureful, GPU-based terminal emulator
@@ -16,6 +17,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}furo>0:textproc/py-furo@${PY_FLAVOR} \
sphinx-build:textproc/py-sphinx@${PY_FLAVOR} \
wayland-protocols>=0:graphics/wayland-protocols
LIB_DEPENDS= libdbus-1.so:devel/dbus \
+ libepoll-shim-interpose.so:devel/libepoll-shim \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libharfbuzz.so:print/harfbuzz \
@@ -26,12 +28,11 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libwayland-cursor.so:graphics/wayland \
libxkbcommon.so:x11/libxkbcommon
-USES= compiler:c11 cpe gettext-runtime gl gmake pkgconfig \
- python:3.5+ shebangfix tar:xz terminfo xorg
-GH_ACCOUNT= kovidgoyal
+USES= compiler:c11 cpe desktop-file-utils gettext-runtime gl gmake \
+ pkgconfig python:3.5+ shebangfix tar:xz terminfo xorg
+CPE_VENDOR= kitty_project
USE_GL= gl
USE_XORG= x11 xcb xcursor xi xinerama xrandr
-CPE_VENDOR= kitty_project
SHEBANG_FILES= build-terminfo count-lines-of-code mypy-editor-integration \
update-on-ox update-on-ubuntu
@@ -40,6 +41,9 @@ SHEBANG_GLOB= *.py
TEST_ENV= PATH="${STAGEDIR}${PREFIX}/bin:${PATH}"
TEST_TARGET= test
+CPPFLAGS+= `pkg-config --cflags epoll-shim-interpose`
+LDFLAGS+= `pkg-config --libs epoll-shim-interpose`
+
BINARY_ALIAS= python3=${PYTHON_CMD} python=${PYTHON_CMD}
INSTALL_WRKSRC= ${WRKSRC}/linux-package
@@ -61,9 +65,14 @@ MAKE_ENV+= KITTY_NO_LTO=1
# ncursesw and tinfo >= 6.1 seem to be neededd
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1400035
-USES+=ncurses:port
+USES+= ncurses:port
.else
-USES+=ncurses
+USES+= ncurses
+.endif
+
+# fix clang static_assert on 12.x releases, https://github.com/kovidgoyal/kitty/pull/5398
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1300000
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-kitty_data-types.h
.endif
# For librsync, we need to set header and library path