aboutsummaryrefslogtreecommitdiff
path: root/x11/libxfce4menu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libxfce4menu/Makefile')
-rw-r--r--x11/libxfce4menu/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/x11/libxfce4menu/Makefile b/x11/libxfce4menu/Makefile
index 8729cac23d12..adb44c4b6e6c 100644
--- a/x11/libxfce4menu/Makefile
+++ b/x11/libxfce4menu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libxfce4menu
PORTVERSION= 4.10.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DISTNAME= libxfce4ui-${PORTVERSION}
@@ -16,14 +16,14 @@ DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Widgets library for the Xfce desktop environment
-USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= glib20 gnomehack gtk20 intltool intlhack pkgconfig desktopfileutils
+USE_GNOME= glib20 gnomehack gtk20 intltool intlhack desktopfileutils
USE_LDCONFIG= yes
USE_XFCE= configenv libutil xfconf
INSTALLS_ICONS= yes
+USE_PKGCONFIG= build
CONFIGURE_ARGS= --disable-gtk-doc-html \
--with-vendor-info=FreeBSD
@@ -64,4 +64,10 @@ CONFIGURE_ARGS+=--enable-gladeui
CONFIGURE_ARGS+=--disable-gladeui
.endif
+.if empty(PORT_OPTIONS:MNLS)
+post-patch:
+ @${REINPLACE_CMD} -e 's|docs \\|docs|| ; \
+ s|po||' ${WRKSRC}/Makefile.in
+.endif
+
.include <bsd.port.mk>