aboutsummaryrefslogtreecommitdiff
path: root/x11/plasma-scriptengine-python
diff options
context:
space:
mode:
Diffstat (limited to 'x11/plasma-scriptengine-python')
-rw-r--r--x11/plasma-scriptengine-python/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/x11/plasma-scriptengine-python/Makefile b/x11/plasma-scriptengine-python/Makefile
index 2c21ea0fa8ac..9ebd090c2a75 100644
--- a/x11/plasma-scriptengine-python/Makefile
+++ b/x11/plasma-scriptengine-python/Makefile
@@ -1,11 +1,9 @@
# $FreeBSD$
PORTNAME= plasma-scriptengine-python
-PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
+PORTVERSION= ${KDE4_WORKSPACE_VERSION}
CATEGORIES= x11 kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_BRANCH}/${KDE4_VERSION}/src
DISTNAME= kde-workspace-${PORTVERSION}
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -14,14 +12,13 @@ COMMENT= Plasma scriptengine for Python
USE_KDE4= kdehier kdelibs kdeprefix pykde4 automoc4
USE_QT4= qmake_build moc_build uic_build rcc_build
-USE_PYTHON= yes
+USE_PYTHON= 2
DISTINFO_FILE= ${PORTSDIR}/x11/kde4-workspace/distinfo
USE_XZ= yes
USES= cmake:outsource
CMAKE_SOURCE_PATH= ${WRKSRC}/plasma/generic/scriptengines/python
-NO_STAGE= yes
pre-configure:
${REINPLACE_CMD} -e 's,$${PYTHON_SITE_PACKAGES_DIR},${PYTHONPREFIX_SITELIBDIR},g' \
${CMAKE_SOURCE_PATH}/CMakeLists.txt