aboutsummaryrefslogtreecommitdiff
path: root/x11/slim
diff options
context:
space:
mode:
Diffstat (limited to 'x11/slim')
-rw-r--r--x11/slim/Makefile4
-rw-r--r--x11/slim/files/patch-png.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/x11/slim/Makefile b/x11/slim/Makefile
index 639148312d0b..6534ffa3d36a 100644
--- a/x11/slim/Makefile
+++ b/x11/slim/Makefile
@@ -7,7 +7,7 @@
PORTNAME= slim
PORTVERSION= 1.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_BERLIOS} \
http://depot.fsck.ch/mirror/distfiles/
@@ -17,7 +17,7 @@ MAINTAINER= henry.hu.sh@gmail.com
COMMENT= Graphical login manager for X11, derived from Login.app
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2 \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig
diff --git a/x11/slim/files/patch-png.c b/x11/slim/files/patch-png.c
new file mode 100644
index 000000000000..06b60c641b5b
--- /dev/null
+++ b/x11/slim/files/patch-png.c
@@ -0,0 +1,11 @@
+--- png.c.orig 2010-07-08 07:04:10.000000000 +0200
++++ png.c 2012-05-06 10:02:42.000000000 +0200
+@@ -57,7 +57,7 @@
+ return(0);
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp) NULL);
+ fclose(infile);