aboutsummaryrefslogtreecommitdiff
path: root/contrib/expat/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/expat/tests/Makefile.am')
-rw-r--r--contrib/expat/tests/Makefile.am62
1 files changed, 47 insertions, 15 deletions
diff --git a/contrib/expat/tests/Makefile.am b/contrib/expat/tests/Makefile.am
index 742ed437dbde..f949fe7f1ab0 100644
--- a/contrib/expat/tests/Makefile.am
+++ b/contrib/expat/tests/Makefile.am
@@ -6,7 +6,9 @@
# \___/_/\_\ .__/ \__,_|\__|
# |_| XML parser
#
-# Copyright (c) 2017 Expat development team
+# Copyright (c) 2017-2023 Sebastian Pipping <sebastian@pipping.org>
+# Copyright (c) 2017-2022 Rhodri James <rhodri@wildebeest.org.uk>
+# Copyright (c) 2020 Jeffrey Walton <noloader@gmail.com>
# Licensed under the MIT license:
#
# Permission is hereby granted, free of charge, to any person obtaining
@@ -30,33 +32,63 @@
SUBDIRS = . benchmark
-AM_CPPFLAGS = -I$(srcdir)/../lib
+AM_CPPFLAGS = @AM_CPPFLAGS@ -I$(srcdir)/../lib
-noinst_LIBRARIES = libruntests.a
-
-check_PROGRAMS = runtests runtestspp
-TESTS = runtests runtestspp
+check_PROGRAMS = runtests runtests_cxx
+TESTS = runtests runtests_cxx
# To support MinGW and Non-MinGW at the same time:
LOG_DRIVER = $(srcdir)/../test-driver-wrapper.sh
-libruntests_a_SOURCES = \
+runtests_SOURCES = \
+ acc_tests.c \
+ alloc_tests.c \
+ basic_tests.c \
chardata.c \
- structdata.c \
+ common.c \
+ dummy.c \
+ handlers.c \
memcheck.c \
- minicheck.c
+ minicheck.c \
+ misc_tests.c \
+ ns_tests.c \
+ nsalloc_tests.c \
+ runtests.c \
+ structdata.c
-runtests_SOURCES = \
- runtests.c
+runtests_cxx_SOURCES = \
+ acc_tests_cxx.cpp \
+ alloc_tests_cxx.cpp \
+ basic_tests_cxx.cpp \
+ chardata_cxx.cpp \
+ common_cxx.cpp \
+ dummy_cxx.cpp \
+ handlers_cxx.cpp \
+ memcheck_cxx.cpp \
+ minicheck_cxx.cpp \
+ misc_tests_cxx.cpp \
+ nsalloc_tests_cxx.cpp \
+ ns_tests_cxx.cpp \
+ runtests_cxx.cpp \
+ structdata_cxx.cpp
-runtestspp_SOURCES = \
- runtestspp.cpp
+runtests_LDADD = ../lib/libexpatinternal.la
+runtests_cxx_LDADD = ../lib/libexpatinternal.la
-runtests_LDADD = libruntests.a ../lib/libexpat.la
-runtestspp_LDADD = libruntests.a ../lib/libexpat.la
+runtests_LDFLAGS = @AM_LDFLAGS@ @LIBM@
+runtests_cxx_LDFLAGS = @AM_LDFLAGS@ @LIBM@
EXTRA_DIST = \
+ acc_tests.h \
+ alloc_tests.h \
+ basic_tests.h \
chardata.h \
+ common.h \
+ dummy.h \
+ handlers.h \
+ misc_tests.h \
+ ns_tests.h \
+ nsalloc_tests.h \
structdata.h \
minicheck.h \
memcheck.h \