aboutsummaryrefslogtreecommitdiff
path: root/contrib/ntp/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/ntp/util/Makefile.am')
-rw-r--r--contrib/ntp/util/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/contrib/ntp/util/Makefile.am b/contrib/ntp/util/Makefile.am
new file mode 100644
index 000000000000..4d703182773f
--- /dev/null
+++ b/contrib/ntp/util/Makefile.am
@@ -0,0 +1,18 @@
+#AUTOMAKE_OPTIONS = ../ansi2knr no-dependencies
+AUTOMAKE_OPTIONS = ansi2knr
+bin_PROGRAMS = @MAKE_TICKADJ@ @MAKE_NTPTIME@
+EXTRA_PROGRAMS = byteorder hist jitter kern longsize ntptime \
+precision tickadj testrs6000 timetrim sht
+
+INCLUDES = -I$(top_srcdir)/include
+# LDADD might need RESLIB and ADJLIB
+LDADD = ../libntp/libntp.a
+#EXTRA_DIST = README TAGS
+EXTRA_DIST =
+ETAGS_ARGS = Makefile.am
+
+../libntp/libntp.a:
+ cd ../libntp && $(MAKE)
+
+kern.o: kern.c
+ $(COMPILE) -DHAVE_TIMEX_H -c kern.c