aboutsummaryrefslogtreecommitdiff
path: root/contrib/perl5/ext/DB_File/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/perl5/ext/DB_File/Makefile.PL')
-rw-r--r--contrib/perl5/ext/DB_File/Makefile.PL20
1 files changed, 20 insertions, 0 deletions
diff --git a/contrib/perl5/ext/DB_File/Makefile.PL b/contrib/perl5/ext/DB_File/Makefile.PL
new file mode 100644
index 000000000000..dbe19f1774ac
--- /dev/null
+++ b/contrib/perl5/ext/DB_File/Makefile.PL
@@ -0,0 +1,20 @@
+use ExtUtils::MakeMaker 5.16 ;
+use Config ;
+
+# OS2 is a special case, so check for it now.
+my $OS2 = "-DOS2" if $Config{'osname'} eq 'os2' ;
+
+my $LIB = "-ldb" ;
+# so is win32
+$LIB = "-llibdb" if $^O eq 'MSWin32' ;
+
+WriteMakefile(
+ NAME => 'DB_File',
+ LIBS => ["-L/usr/local/lib $LIB"],
+ MAN3PODS => ' ', # Pods will be built by installman.
+ #INC => '-I/usr/local/include',
+ VERSION_FROM => 'DB_File.pm',
+ XSPROTOARG => '-noprototypes',
+ DEFINE => "$OS2",
+ );
+