aboutsummaryrefslogtreecommitdiff
path: root/sys/contrib/openzfs/tests/zfs-tests/tests/functional/hkdf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/contrib/openzfs/tests/zfs-tests/tests/functional/hkdf/Makefile.am')
-rw-r--r--sys/contrib/openzfs/tests/zfs-tests/tests/functional/hkdf/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/sys/contrib/openzfs/tests/zfs-tests/tests/functional/hkdf/Makefile.am b/sys/contrib/openzfs/tests/zfs-tests/tests/functional/hkdf/Makefile.am
new file mode 100644
index 000000000000..8ac9053223a4
--- /dev/null
+++ b/sys/contrib/openzfs/tests/zfs-tests/tests/functional/hkdf/Makefile.am
@@ -0,0 +1,17 @@
+include $(top_srcdir)/config/Rules.am
+
+pkgdatadir = $(datadir)/@PACKAGE@/zfs-tests/tests/functional/hkdf
+
+dist_pkgdata_SCRIPTS = \
+ setup.ksh \
+ cleanup.ksh \
+ run_hkdf_test.ksh
+
+pkgexecdir = $(datadir)/@PACKAGE@/zfs-tests/tests/functional/hkdf
+
+pkgexec_PROGRAMS = \
+ hkdf_test
+
+hkdf_test_SOURCES = hkdf_test.c
+hkdf_test_LDADD = \
+ $(abs_top_builddir)/lib/libzpool/libzpool.la