aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:01:11 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:01:11 +0000
commit0ba67e8c24ebf591391faf9fdb36dfc1e15da3cd (patch)
tree77d02e2c604e1cc43683c73731c263fa266ced8d
parent66da2e249cde4a8b680854c0ebd1fe8f45334c75 (diff)
downloadports-0ba67e8c24ebf591391faf9fdb36dfc1e15da3cd.tar.gz
ports-0ba67e8c24ebf591391faf9fdb36dfc1e15da3cd.zip
devel/py-xstatic-jquery-ui: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--devel/py-xstatic-jquery-ui/Makefile6
-rw-r--r--devel/py-xstatic-jquery-ui/files/patch-setup.py11
2 files changed, 15 insertions, 2 deletions
diff --git a/devel/py-xstatic-jquery-ui/Makefile b/devel/py-xstatic-jquery-ui/Makefile
index 6262037ac49d..c500dc63a5d4 100644
--- a/devel/py-xstatic-jquery-ui/Makefile
+++ b/devel/py-xstatic-jquery-ui/Makefile
@@ -1,6 +1,6 @@
PORTNAME= xstatic-jquery-ui
PORTVERSION= 1.13.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,10 +13,12 @@ WWW= https://jqueryui.com/ \
LICENSE= MIT
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xstatic-jquery>=0:devel/py-xstatic-jquery@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/devel/py-xstatic-jquery-ui/files/patch-setup.py b/devel/py-xstatic-jquery-ui/files/patch-setup.py
new file mode 100644
index 000000000000..8ecb43b06b6f
--- /dev/null
+++ b/devel/py-xstatic-jquery-ui/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2021-11-21 16:29:12 UTC
++++ setup.py
+@@ -7,7 +7,7 @@ setup(
+ from setuptools import setup, find_packages
+
+ setup(
+- name=xs.PACKAGE_NAME,
++ name='xstatic-jquery-ui',
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
+ long_description=long_description,