aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-07-15 16:48:52 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-07-15 16:48:52 +0000
commit0f6c12ee3ae4548f3db457f6c1df7a7584c1dce9 (patch)
tree0de8faa2f570411c33e293aa9dea263d8982a8eb
parente9e4112b1ece6e5abd2c6acff78e134d0e0d44bf (diff)
downloadports-0f6c12ee3ae4548f3db457f6c1df7a7584c1dce9.tar.gz
ports-0f6c12ee3ae4548f3db457f6c1df7a7584c1dce9.zip
x11/lxpanel: update WWW, cleanup one patch, take maintainership
LXDE wiki 404's now, point WWW to their GitHub page (could be temporarily) and drop one patch hunk which was removing already commented out piece of code.
-rw-r--r--x11/lxpanel/Makefile4
-rw-r--r--x11/lxpanel/files/patch-plugins_cpufreq_cpufreq.c99
2 files changed, 2 insertions, 101 deletions
diff --git a/x11/lxpanel/Makefile b/x11/lxpanel/Makefile
index addd6380a199..6cbd2edc416c 100644
--- a/x11/lxpanel/Makefile
+++ b/x11/lxpanel/Makefile
@@ -4,9 +4,9 @@ PORTREVISION= 4
CATEGORIES= x11
MASTER_SITES= SF/lxde/LXPanel%20%28desktop%20panel%29/LXPanel%20${PORTVERSION:R}.x/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Lightweight X11 desktop panel
-WWW= https://wiki.lxde.org/en/LXPanel
+WWW= https://github.com/lxde/lxpanel
LICENSE= GPLv2+ MIT
LICENSE_COMB= multi
diff --git a/x11/lxpanel/files/patch-plugins_cpufreq_cpufreq.c b/x11/lxpanel/files/patch-plugins_cpufreq_cpufreq.c
index 7307c40ef526..aa7046462d98 100644
--- a/x11/lxpanel/files/patch-plugins_cpufreq_cpufreq.c
+++ b/x11/lxpanel/files/patch-plugins_cpufreq_cpufreq.c
@@ -48,105 +48,6 @@
static void
get_cur_governor(cpufreq *cf){
FILE *fp;
-@@ -99,98 +108,6 @@ get_cur_freq(cpufreq *cf){
- }
- }
-
--/*static void
--get_governors(cpufreq *cf){
-- FILE *fp;
-- GList *l;
-- char buf[ 100 ], sstmp [ 256 ], c, bufl = 0;
--
-- g_list_free(cf->governors);
-- cf->governors = NULL;
--
-- get_cur_governor(cf);
--
-- if(cf->cpus == NULL){
-- cf->governors = NULL;
-- return;
-- }
-- sprintf(sstmp,"%s/%s",cf->cpus->data, SCALING_AGOV);
--
-- if (!(fp = fopen( sstmp, "r"))) {
-- printf("cpufreq: cannot open %s\n",sstmp);
-- return;
-- }
--
-- while((c = fgetc(fp)) != EOF){
-- if(c == ' '){
-- if(bufl > 1){
-- buf[bufl] = '\0';
-- cf->governors = g_list_append(cf->governors, strdup(buf));
-- }
-- bufl = 0;
-- buf[0] = '\0';
-- }else{
-- buf[bufl++] = c;
-- }
-- }
--
-- fclose(fp);
--}
--
--static void
--cpufreq_set_freq(GtkWidget *widget, Param* p){
-- FILE *fp;
-- char buf[ 100 ], sstmp [ 256 ];
--
-- if(strcmp(p->cf->cur_governor, "userspace")) return;
--
-- sprintf(sstmp,"%s/%s",p->cf->cpus->data, SCALING_SETFREQ);
-- if ((fp = fopen( sstmp, "w")) != NULL) {
-- fprintf(fp,"%s",p->data);
-- fclose(fp);
-- }
--}
--
--static GtkWidget *
--frequency_menu(cpufreq *cf){
-- FILE *fp;
-- Param* param;
-- char buf[ 100 ], sstmp [ 256 ], c, bufl = 0;
--
-- sprintf(sstmp,"%s/%s",cf->cpus->data, SCALING_AFREQ);
--
-- if (!(fp = fopen( sstmp, "r"))) {
-- printf("cpufreq: cannot open %s\n",sstmp);
-- return 0;
-- }
--
-- GtkMenu* menu = GTK_MENU(gtk_menu_new());
-- GtkWidget* menuitem;
--
-- while((c = fgetc(fp)) != EOF){
-- if(c == ' '){
-- if(bufl > 1){
-- buf[bufl] = '\0';
-- menuitem = gtk_menu_item_new_with_label(strdup(buf));
-- gtk_menu_append (GTK_MENU_SHELL (menu), menuitem);
-- gtk_widget_show (menuitem);
-- param = g_new0(Param, 1);
-- param->data = strdup(buf);
-- param->cf = cf;
-- g_signal_connect(G_OBJECT(menuitem), "activate", G_CALLBACK(cpufreq_set_freq), param);
-- g_object_weak_ref(G_OBJECT(menuitem), (GWeakNotify)g_free, param);
-- }
-- bufl = 0;
-- buf[0] = '\0';
-- }else{
-- buf[bufl++] = c;
-- }
-- }
--
-- fclose(fp);
-- return GTK_WIDGET(menu);
--}*/
--
- static void
- get_cpus(cpufreq *cf)
- {
@@ -227,72 +144,49 @@ get_cpus(cpufreq *cf)
}
g_dir_close(cpuDirectory);