aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2021-04-23 14:30:01 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2021-04-25 06:42:11 +0000
commit106aa36f9d8d295d8395ffdf65716717d3c89516 (patch)
treea58d5540927c5bc810e63793145e0b90dc563f5a
parentce144dc8c7b36f15dc9d1fd4cba1226c776f3e77 (diff)
downloadports-106aa36f9d8d295d8395ffdf65716717d3c89516.tar.gz
ports-106aa36f9d8d295d8395ffdf65716717d3c89516.zip
net-mgmt/virt-viewer: update to 10.0
- virt-viewer has moved from autotools to meson, make changes accordingly - add options for features that previously were unconditionally enabled; these are still enabled by default - NLS options is gone as it cannot be disabled anymore
-rw-r--r--net-mgmt/virt-viewer/Makefile51
-rw-r--r--net-mgmt/virt-viewer/distinfo6
-rw-r--r--net-mgmt/virt-viewer/files/patch-data_meson.build11
-rw-r--r--net-mgmt/virt-viewer/pkg-plist139
4 files changed, 85 insertions, 122 deletions
diff --git a/net-mgmt/virt-viewer/Makefile b/net-mgmt/virt-viewer/Makefile
index 06e45ad2a108..19b76f5100b0 100644
--- a/net-mgmt/virt-viewer/Makefile
+++ b/net-mgmt/virt-viewer/Makefile
@@ -1,7 +1,7 @@
# Created by: Jason Helfman <jgh@FreeBSD.org>
PORTNAME= virt-viewer
-PORTVERSION= 9.0
+PORTVERSION= 10.0
CATEGORIES= net-mgmt
MASTER_SITES= https://virt-manager.org/download/sources/${PORTNAME}/
@@ -10,28 +10,39 @@ COMMENT= Provides a graphical viewer for a guest OS display
LICENSE= GPLv2
-BUILD_DEPENDS= xml2-config:textproc/libxml2 \
- intltoolize:textproc/intltool \
- spice-protocol>=0.12.7:devel/spice-protocol
-LIB_DEPENDS= libvirt.so:devel/libvirt \
- libvirt-glib-1.0.so:devel/libvirt-glib \
- libgtk-vnc-2.0.so:net/gtk-vnc \
- libspice-client-glib-2.0.so:deskutils/spice-gtk
+USES= cpe desktop-file-utils gettext gettext-tools gmake gnome \
+ libtool meson pkgconfig python:3.6+,build shared-mime-info xorg tar:xz
+CPE_VENDOR= redhat
+USE_GNOME= gtk30 libxml2
+INSTALLS_ICONS= yes
+USE_XORG= xorgproto
+BINARY_ALIAS= python3=${PYTHON_CMD}
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= SPICE VNC LIBVIRT VTE
+OPTIONS_DEFAULT= SPICE VNC LIBVIRT VTE
OPTIONS_SUB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV+= DATADIRNAME=share
-CONFIGURE_ARGS= --with-spice-gtk
-USES= autoreconf cpe desktop-file-utils gettext-tools gmake gnome \
- libtool pkgconfig shared-mime-info xorg
-USE_GNOME= gtk30
-USE_XORG= xorgproto
-INSTALLS_ICONS= yes
-CPE_VENDOR= redhat
+SPICE_DESC= SPICE support
+VNC_DESC= VNC support
+VTE_DESC= VTE support
+
+LIBVIRT_LIB_DEPENDS= libvirt.so:devel/libvirt \
+ libvirt-glib-1.0.so:devel/libvirt-glib
+LIBVIRT_MESON_ENABLED= libvirt
+
+SPICE_BUILD_DEPENDS= spice-protocol>=0.12.7:devel/spice-protocol
+SPICE_LIB_DEPENDS= libspice-client-glib-2.0.so:deskutils/spice-gtk
+SPICE_MESON_ENABLED= spice
+
+VNC_LIB_DEPENDS= libgtk-vnc-2.0.so:net/gtk-vnc
+VNC_MESON_ENABLED= vnc
+
+VTE_MESON_ENABLED= vte
+
+.include <bsd.port.options.mk>
-NLS_USES= gettext
-NLS_CONFIGURE_ENABLE= nls
+.if ${PORT_OPTIONS:MVTE}
+USE_GNOME+= vte3
+.endif
.include <bsd.port.mk>
diff --git a/net-mgmt/virt-viewer/distinfo b/net-mgmt/virt-viewer/distinfo
index 586bb5554110..2d969e690933 100644
--- a/net-mgmt/virt-viewer/distinfo
+++ b/net-mgmt/virt-viewer/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588417860
-SHA256 (virt-viewer-9.0.tar.gz) = 91b43383a0bd4cf3173269e674d65fd205f7c34bc5a8cb4fb3640deb7f1d4825
-SIZE (virt-viewer-9.0.tar.gz) = 1176991
+TIMESTAMP = 1619181098
+SHA256 (virt-viewer-10.0.tar.xz) = d23bc0a06e4027c37b8386cfd0286ef37bd738977153740ab1b6b331192389c5
+SIZE (virt-viewer-10.0.tar.xz) = 256372
diff --git a/net-mgmt/virt-viewer/files/patch-data_meson.build b/net-mgmt/virt-viewer/files/patch-data_meson.build
new file mode 100644
index 000000000000..3b5167c63c0a
--- /dev/null
+++ b/net-mgmt/virt-viewer/files/patch-data_meson.build
@@ -0,0 +1,11 @@
+--- data/meson.build.orig 2021-04-24 00:07:18 UTC
++++ data/meson.build
+@@ -33,7 +33,7 @@ if host_machine.system() != 'windows'
+ output: metainfo,
+ po_dir: po_dir,
+ install: true,
+- install_dir: join_paths(datadir, 'metainfo')
++ install_dir: join_paths(datadir, 'appdata')
+ )
+ endif
+
diff --git a/net-mgmt/virt-viewer/pkg-plist b/net-mgmt/virt-viewer/pkg-plist
index b1c4be107e18..d55d7446aa5e 100644
--- a/net-mgmt/virt-viewer/pkg-plist
+++ b/net-mgmt/virt-viewer/pkg-plist
@@ -1,5 +1,5 @@
bin/remote-viewer
-bin/virt-viewer
+%%LIBVIRT%%bin/virt-viewer
man/man1/remote-viewer.1.gz
man/man1/virt-viewer.1.gz
share/appdata/remote-viewer.appdata.xml
@@ -8,105 +8,46 @@ share/applications/remote-viewer.desktop
share/icons/hicolor/16x16/apps/virt-viewer.png
share/icons/hicolor/22x22/apps/virt-viewer.png
share/icons/hicolor/24x24/apps/virt-viewer.png
-share/icons/hicolor/24x24/devices/virt-viewer-usb.png
-share/icons/hicolor/24x24/devices/virt-viewer-usb.svg
share/icons/hicolor/256x256/apps/virt-viewer.png
share/icons/hicolor/32x32/apps/virt-viewer.png
share/icons/hicolor/48x48/apps/virt-viewer.png
+share/icons/hicolor/scalable/apps/virt-viewer.svg
share/mime/packages/virt-viewer-mime.xml
-%%NLS%%share/locale/af/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/am/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/anp/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ar/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/as/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ast/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/bal/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/be/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/bg/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/bn/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/bn_IN/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/bo/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/br/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/brx/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/bs/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ca/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/cs/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/cy/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/da/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/de/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/de_CH/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/el/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/en_GB/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/eo/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/es/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/et/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/eu/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/fa/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/fi/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/gl/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/gu/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/he/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/hi/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/hr/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ia/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/id/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ilo/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/is/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/it/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ka/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/kk/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/km/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/kn/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ko/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/kw/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/kw@kkcor/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/kw@uccor/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/kw_GB/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ky/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/lt/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/lv/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/mai/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/mk/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ml/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/mn/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/mr/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ms/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/nb/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/nds/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ne/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/nn/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/nso/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/or/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/pa/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/pt/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ro/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/si/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/sk/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/sl/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/sq/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/sr/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/sr@latin/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ta/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/te/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/tg/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/th/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/tr/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/tw/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/ur/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/vi/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/wba/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/yo/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/zh_HK/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/virt-viewer.mo
-%%NLS%%share/locale/zu/LC_MESSAGES/virt-viewer.mo
-share/mime/application/x-virt-viewer.xml
+share/locale/as/LC_MESSAGES/virt-viewer.mo
+share/locale/bg/LC_MESSAGES/virt-viewer.mo
+share/locale/bn/LC_MESSAGES/virt-viewer.mo
+share/locale/bn_IN/LC_MESSAGES/virt-viewer.mo
+share/locale/ca/LC_MESSAGES/virt-viewer.mo
+share/locale/cs/LC_MESSAGES/virt-viewer.mo
+share/locale/de/LC_MESSAGES/virt-viewer.mo
+share/locale/es/LC_MESSAGES/virt-viewer.mo
+share/locale/eu/LC_MESSAGES/virt-viewer.mo
+share/locale/fi/LC_MESSAGES/virt-viewer.mo
+share/locale/fr/LC_MESSAGES/virt-viewer.mo
+share/locale/gu/LC_MESSAGES/virt-viewer.mo
+share/locale/hi/LC_MESSAGES/virt-viewer.mo
+share/locale/hu/LC_MESSAGES/virt-viewer.mo
+share/locale/id/LC_MESSAGES/virt-viewer.mo
+share/locale/it/LC_MESSAGES/virt-viewer.mo
+share/locale/ja/LC_MESSAGES/virt-viewer.mo
+share/locale/kn/LC_MESSAGES/virt-viewer.mo
+share/locale/ko/LC_MESSAGES/virt-viewer.mo
+share/locale/ml/LC_MESSAGES/virt-viewer.mo
+share/locale/mr/LC_MESSAGES/virt-viewer.mo
+share/locale/nb/LC_MESSAGES/virt-viewer.mo
+share/locale/nl/LC_MESSAGES/virt-viewer.mo
+share/locale/or/LC_MESSAGES/virt-viewer.mo
+share/locale/pa/LC_MESSAGES/virt-viewer.mo
+share/locale/pl/LC_MESSAGES/virt-viewer.mo
+share/locale/pt/LC_MESSAGES/virt-viewer.mo
+share/locale/pt_BR/LC_MESSAGES/virt-viewer.mo
+share/locale/ru/LC_MESSAGES/virt-viewer.mo
+share/locale/si/LC_MESSAGES/virt-viewer.mo
+share/locale/sk/LC_MESSAGES/virt-viewer.mo
+share/locale/sv/LC_MESSAGES/virt-viewer.mo
+share/locale/ta/LC_MESSAGES/virt-viewer.mo
+share/locale/te/LC_MESSAGES/virt-viewer.mo
+share/locale/tr/LC_MESSAGES/virt-viewer.mo
+share/locale/uk/LC_MESSAGES/virt-viewer.mo
+share/locale/zh_CN/LC_MESSAGES/virt-viewer.mo
+share/locale/zh_TW/LC_MESSAGES/virt-viewer.mo