aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-12-30 08:55:17 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-12-30 09:06:33 +0000
commit1626e9a9a59cf12d9757f49f9991e6bd531c768e (patch)
tree6a886d7e40bc3c8690ee8c10ebabac02737333cb
parentb59d2f879d2123a09d4563a006443659128213ae (diff)
downloadports-1626e9a9a59cf12d9757f49f9991e6bd531c768e.tar.gz
ports-1626e9a9a59cf12d9757f49f9991e6bd531c768e.zip
lang/ruby32: Fix orphaned .timestamp in b49bdb1fe4680488411546540e6f737770a6003b
When both CAPIDOCS and DOCS options are enabled, the following commands are executed: 1. post-install-CAPIDOCS-on: removed the installed .timestamp (in STAGEDIR). 2. post-install-DOCS-on: copied the generated .timestamp (in capi directory) to the STAGEDIR again. Therefore, the installed .timestamp is orphaned. To fix this, we remove both the generated and installed .timestamp in post-install-CAPIDOCS-on:. PR: 267775 Reported by: yasu
-rw-r--r--lang/ruby32/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/ruby32/Makefile b/lang/ruby32/Makefile
index 3f35054828df..7ac4d13817e0 100644
--- a/lang/ruby32/Makefile
+++ b/lang/ruby32/Makefile
@@ -183,7 +183,7 @@ post-install:
.endif
post-install-CAPIDOCS-on:
- ${RM} ${STAGEDIR}${PREFIX}/share/doc/ruby${RUBY_SUFFIX}/capi/.timestamp
+ ${RM} ${WRKSRC}/doc/capi/.timestamp ${STAGEDIR}${PREFIX}/share/doc/ruby${RUBY_SUFFIX}/capi/.timestamp
cd ${STAGEDIR}${PREFIX} && ${FIND} share/doc/ruby${RUBY_SUFFIX}/capi/ -type f >> ${TMPPLIST}
post-install-DEBUG-off:
@@ -204,7 +204,7 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/ext/${FILE} \
${STAGEDIR}${RUBY_DOCDIR}/${FILE:C|^([^/]+)/.*|\1|}/
.endfor
- @(cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${RUBY_DOCDIR}/ "! -name .timestamp")
+ @(cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${RUBY_DOCDIR}/)
${INSTALL_DATA} ${WRKSRC}/COPYING* \
${WRKSRC}/ChangeLog \
${WRKSRC}/LEGAL \