aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg A. Mamontov <oleg@mamontov.net>2023-08-07 18:32:57 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-08-09 13:01:16 +0000
commit28f5935e59a9fc08dc7c0abcb6a1161431964464 (patch)
treef63496f27bc879d749e872ee8885d07f9ffb95d1
parent8b299dec679441240f27cff3577a8a5b60fc6c9a (diff)
downloadports-28f5935e59a9fc08dc7c0abcb6a1161431964464.tar.gz
ports-28f5935e59a9fc08dc7c0abcb6a1161431964464.zip
www/angie-module-jwt: Angie JWT dynamic module
Module provides JWT validity check funcionality for Angie. PR: 272999
-rw-r--r--www/Makefile1
-rw-r--r--www/angie-module-jwt/Makefile27
-rw-r--r--www/angie-module-jwt/files/pkg-message.in15
-rw-r--r--www/angie-module-jwt/pkg-descr3
-rw-r--r--www/angie-module-jwt/pkg-plist3
5 files changed, 49 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 07be8a226767..c60508f1ebc2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -32,6 +32,7 @@
SUBDIR += angie-module-cache-purge
SUBDIR += angie-module-geoip2
SUBDIR += angie-module-image-filter
+ SUBDIR += angie-module-jwt
SUBDIR += anyremote2html
SUBDIR += apache-mode.el
SUBDIR += apache24
diff --git a/www/angie-module-jwt/Makefile b/www/angie-module-jwt/Makefile
new file mode 100644
index 000000000000..62ee1ce0f589
--- /dev/null
+++ b/www/angie-module-jwt/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= angie-module-jwt
+GH_TUPLE= max-lt:nginx-jwt-module:v3.2.2:module
+
+COMMENT= Angie JWT dynamic module
+
+LIB_DEPENDS= libjansson.so:devel/jansson \
+ libjwt.so:www/libjwt
+
+MASTERDIR= ${.CURDIR}/../../www/angie
+
+CONFLICTS= www/angie-module-auth-jwt
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_LIB} ${WRKSRC}/objs/ngx_http_auth_jwt_module.so \
+ ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_MAN} ${WRKSRC_module}/README.md ${STAGEDIR}${DOCSDIR}
+
+do-install-DEBUG-on:
+ ${INSTALL} ${COPY} -m ${_SHAREMODE} \
+ ${WRKSRC_DEBUG}/objs/ngx_http_auth_jwt_module.so \
+ ${STAGEDIR}${MODDIR}/ngx_http_auth_jwt_module-debug.so
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/angie-module-jwt/files/pkg-message.in b/www/angie-module-jwt/files/pkg-message.in
new file mode 100644
index 000000000000..e3fbe2dc1c6c
--- /dev/null
+++ b/www/angie-module-jwt/files/pkg-message.in
@@ -0,0 +1,15 @@
+[
+{ type: install
+ message: <<EOM
+
+The jwt dynamic module for Angie has been installed.
+To enable this module, add the following to %%PREFIX%%/etc/angie/angie.conf
+and reload angie:
+
+ load_module modules/ngx_http_auth_jwt_module.so;
+
+Please refer to the module documentation for further details:
+https://github.com/max-lt/nginx-jwt-module
+EOM
+}
+]
diff --git a/www/angie-module-jwt/pkg-descr b/www/angie-module-jwt/pkg-descr
new file mode 100644
index 000000000000..901540b262af
--- /dev/null
+++ b/www/angie-module-jwt/pkg-descr
@@ -0,0 +1,3 @@
+Module provides JWT validity check functionality for Angie.
+Module intends to be as light as possible and to remain simple.
+Supports number of key encodings and allows to keep it in a designated file.
diff --git a/www/angie-module-jwt/pkg-plist b/www/angie-module-jwt/pkg-plist
new file mode 100644
index 000000000000..52be19d191b7
--- /dev/null
+++ b/www/angie-module-jwt/pkg-plist
@@ -0,0 +1,3 @@
+%%DOCSDIR%%/README.md
+%%MODDIR%%/ngx_http_auth_jwt_module.so
+%%DEBUG%%%%MODDIR%%/ngx_http_auth_jwt_module-debug.so