aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-06 11:15:00 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-06 12:03:04 +0000
commit2f28d70fcbc01d8963dedb3df92c4abcd334c675 (patch)
tree4490da4af0529f66f9cd1698b18d5f1f8c1da43d
parent6b139f669d8f399035e0f653b7afcefe37a6bb53 (diff)
downloadports-2f28d70fcbc01d8963dedb3df92c4abcd334c675.tar.gz
ports-2f28d70fcbc01d8963dedb3df92c4abcd334c675.zip
emulators/advancemenu: prepare for freetype2 update
- freetype2 will no longer ship freetype-config (which was a pkg-config wrapper) in the near future -- use pkg-config to gather the required flags by mocking freetype-config. - while here, mark as abandonware - port has version 2.8 is from 07-08-2015 - upstream version 3.0 is from 04-12-2016
-rw-r--r--emulators/advancemenu/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/emulators/advancemenu/Makefile b/emulators/advancemenu/Makefile
index 4a8ecafabeae..f0294a4d0c7c 100644
--- a/emulators/advancemenu/Makefile
+++ b/emulators/advancemenu/Makefile
@@ -33,14 +33,23 @@ OPTIONS_DEFAULT_i386= ASM
ASM_BUILD_DEPENDS= nasm:devel/nasm
ASM_USE= gcc=any
ASM_CONFIGURE_ENABLE= asm
+FREETYPE_USES= pkgconfig
FREETYPE_LIB_DEPENDS= libfreetype.so:print/freetype2
FREETYPE_CONFIGURE_ENABLE= freetype
+DEPRECATED= Heavily outdated and unmaintained
+EXPIRATION_DATE= 2021-10-31
+
+BINARY_ALIAS= freetype-config=${WRKSRC}/freetype-config-dummy
+
post-patch:
@${REINPLACE_CMD} -e \
's|-lpthread|-pthread|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
's|@@|@|' ${WRKSRC}/Makefile.in
+ # Mock freetype-config script
+ echo -e '#!/bin/sh\npkg-config freetype2 $$*' >> ${WRKSRC}/freetype-config-dummy
+ chmod +x ${WRKSRC}/freetype-config-dummy
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/advmenu ${STAGEDIR}${PREFIX}/bin