aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg A. Mamontov <oleg@mamontov.net>2023-08-07 18:34:43 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-08-09 13:01:16 +0000
commit31122efc5f250eb707758ddd6aab8f858d73fad9 (patch)
treeadc6e26465c4496191290bf9d0ea479b13c11316
parent28f5935e59a9fc08dc7c0abcb6a1161431964464 (diff)
downloadports-31122efc5f250eb707758ddd6aab8f858d73fad9.tar.gz
ports-31122efc5f250eb707758ddd6aab8f858d73fad9.zip
www/angie-module-keyval: Angie keyval dynamic module
This Angie module creates variables with values taken from key-value pairs. PR: 272999
-rw-r--r--www/Makefile1
-rw-r--r--www/angie-module-keyval/Makefile24
-rw-r--r--www/angie-module-keyval/files/pkg-message.in15
-rw-r--r--www/angie-module-keyval/pkg-descr3
-rw-r--r--www/angie-module-keyval/pkg-plist3
5 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c60508f1ebc2..f06151a65b6a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -33,6 +33,7 @@
SUBDIR += angie-module-geoip2
SUBDIR += angie-module-image-filter
SUBDIR += angie-module-jwt
+ SUBDIR += angie-module-keyval
SUBDIR += anyremote2html
SUBDIR += apache-mode.el
SUBDIR += apache24
diff --git a/www/angie-module-keyval/Makefile b/www/angie-module-keyval/Makefile
new file mode 100644
index 000000000000..c951ba0cb89e
--- /dev/null
+++ b/www/angie-module-keyval/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= angie-module-keyval
+GH_TUPLE= kjdev:nginx-keyval:0.1.0:module
+
+COMMENT= Angie keyval dynamic module
+
+LIB_DEPENDS= libhiredis.so:databases/hiredis
+
+MASTERDIR= ${.CURDIR}/../../www/angie
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_LIB} ${WRKSRC}/objs/ngx_http_keyval_module.so \
+ ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_MAN} ${WRKSRC_module}/README.md ${STAGEDIR}${DOCSDIR}
+
+do-install-DEBUG-on:
+ ${INSTALL} ${COPY} -m ${_SHAREMODE} \
+ ${WRKSRC_DEBUG}/objs/ngx_http_keyval_module.so \
+ ${STAGEDIR}${MODDIR}/ngx_http_keyval_module-debug.so
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/angie-module-keyval/files/pkg-message.in b/www/angie-module-keyval/files/pkg-message.in
new file mode 100644
index 000000000000..ff70758a61d9
--- /dev/null
+++ b/www/angie-module-keyval/files/pkg-message.in
@@ -0,0 +1,15 @@
+[
+{ type: install
+ message: <<EOM
+
+The keyval dynamic module for Angie has been installed.
+To enable this module, add the following to %%PREFIX%%/etc/angie/angie.conf
+and reload angie:
+
+ load_module modules/ngx_http_keyval_module.so;
+
+Please refer to the module documentation for further details:
+https://github.com/kjdev/nginx-keyval
+EOM
+}
+]
diff --git a/www/angie-module-keyval/pkg-descr b/www/angie-module-keyval/pkg-descr
new file mode 100644
index 000000000000..301a78aa8d63
--- /dev/null
+++ b/www/angie-module-keyval/pkg-descr
@@ -0,0 +1,3 @@
+Module creates variables with values taken from key-value pairs.
+Key-value database is stored in shared memory or Redis as specified by the
+configuration parameter.
diff --git a/www/angie-module-keyval/pkg-plist b/www/angie-module-keyval/pkg-plist
new file mode 100644
index 000000000000..61bab19aaafd
--- /dev/null
+++ b/www/angie-module-keyval/pkg-plist
@@ -0,0 +1,3 @@
+%%DOCSDIR%%/README.md
+%%MODDIR%%/ngx_http_keyval_module.so
+%%DEBUG%%%%MODDIR%%/ngx_http_keyval_module-debug.so