aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2023-09-27 14:03:27 +0000
committerDima Panov <fluffy@FreeBSD.org>2023-09-27 14:36:29 +0000
commit358336d31aa7b14c5b62e4ad128c2d4454f0c954 (patch)
treea9f497a6915395284873591656aa89dc66a24d40
parent50ace901b044edd6b46a0e5ad59f4b76733da90c (diff)
downloadports-358336d31aa7b14c5b62e4ad128c2d4454f0c954.tar.gz
ports-358336d31aa7b14c5b62e4ad128c2d4454f0c954.zip
games/wesnoth: update to 1.16.10 release, support Boost-1.83.0 (+)
-rw-r--r--games/wesnoth/Makefile14
-rw-r--r--games/wesnoth/distinfo6
-rw-r--r--games/wesnoth/files/patch-boost-1.8326
3 files changed, 36 insertions, 10 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index bfbf570b119a..0c831f717705 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -1,5 +1,5 @@
PORTNAME= wesnoth
-PORTVERSION= 1.16.9
+PORTVERSION= 1.16.10
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTNAME}-${PORTVERSION} \
@@ -22,16 +22,16 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libicudata.so:devel/icu \
libharfbuzz.so:print/harfbuzz
-LDFLAGS+= -L${LOCALBASE}/lib -lboost_system
-
-PORTSCOUT= limitw:1,even
-
-USES= cmake compiler:c++17-lang cpe gnome pkgconfig \
+USES= cmake compiler:c++17-lang cpe desktop-file-utils gnome pkgconfig \
python:run readline shebangfix ssl sdl tar:bzip2 xorg
USE_SDL= image2 mixer2 ttf2
-USE_LDCONFIG= yes
USE_GNOME= cairo pango
USE_XORG= ice sm x11 xext
+
+LDFLAGS+= -L${LOCALBASE}/lib -lboost_system
+
+PORTSCOUT= limitw:1,even
+
SHEBANG_FILES= data/tools/about_cfg_to_wiki \
data/tools/addon_manager/html.py \
data/tools/expand-terrain-macros.py \
diff --git a/games/wesnoth/distinfo b/games/wesnoth/distinfo
index 59e9d0236ec7..14fe12a9e6b8 100644
--- a/games/wesnoth/distinfo
+++ b/games/wesnoth/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1681753961
-SHA256 (wesnoth-1.16.9.tar.bz2) = 3ded6938fb24100b9884ab5a902711f6c7a25cef65aafddb3e3b8a15b7652386
-SIZE (wesnoth-1.16.9.tar.bz2) = 476167874
+TIMESTAMP = 1695160694
+SHA256 (wesnoth-1.16.10.tar.bz2) = a60521b1ee1c2ddc7dfde89a038b893a4b43337085bd1478f4bc92dab7da7fc7
+SIZE (wesnoth-1.16.10.tar.bz2) = 476195873
diff --git a/games/wesnoth/files/patch-boost-1.83 b/games/wesnoth/files/patch-boost-1.83
new file mode 100644
index 000000000000..b3161206616e
--- /dev/null
+++ b/games/wesnoth/files/patch-boost-1.83
@@ -0,0 +1,26 @@
+From 136e651d69fc91fa7a4154f8a4a7e977cc46eca4 Mon Sep 17 00:00:00 2001
+From: Pentarctagon <pentarctagon@tutamail.com>
+Date: Thu, 17 Aug 2023 23:19:21 -0500
+Subject: [PATCH] Compile fix for boost 1.83.
+
+Fixes #7849
+---
+ src/gettext.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git src/gettext.cpp src/gettext.cpp
+index 9888dede35ad..fa9b17ba85b2 100644
+--- src/gettext.cpp
++++ src/gettext.cpp
+@@ -169,7 +169,11 @@ namespace
+ return msg;
+ }
+
++#if BOOST_VERSION < 108300
+ const char* get(int domain_id, const char* ctx, const char* sid, int n) const override
++#else
++ const char* get(int domain_id, const char* ctx, const char* sid, bl::count_type n) const override
++#endif
+ {
+ auto& base = get_base();
+ const char* msg = base.get(domain_id, ctx, sid, n);