aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2021-06-27 09:30:39 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-06-27 09:30:39 +0000
commit389294d2b118284d007bf6a6df9b2530e4d6348a (patch)
tree87f5cf06fe508bce4027765e87bee90375feb9dd
parente9946a7d27c82dbab07c6bd8d37ec10a14692c40 (diff)
downloadports-389294d2b118284d007bf6a6df9b2530e4d6348a.tar.gz
ports-389294d2b118284d007bf6a6df9b2530e4d6348a.zip
biology/jalview: Fix build
When switching the build dependency from devel/gradle to devel/gradle6, the build is accidentally broken. This attempts to revert part of the change and fix build. Fixes: 55044a2200a4c42b6b653349f0a65dfca3f96f36 Approved by: lwhsu (mentor, implicit), portmgr (fix build)
-rw-r--r--biology/jalview/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/biology/jalview/Makefile b/biology/jalview/Makefile
index f3810e2415e8..b41d1b9abf27 100644
--- a/biology/jalview/Makefile
+++ b/biology/jalview/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_FreeBSD_11= gradle daemon systematically fails on 11: The message received from the daemon indicates that the daemon has disappeared.
-BUILD_DEPENDS= gradle6:devel/gradle6
+BUILD_DEPENDS= gradle:devel/gradle6
USE_JAVA= yes
JAVA_VERSION= 11
@@ -61,7 +61,7 @@ PLIST_FILES= bin/jalview \
${DATADIR}/jalview.jar
do-build:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gradle6 \
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gradle \
--gradle-user-home ${DEPS_CACHE_DIR}/gradle-${PORTNAME} --project-cache-dir ${DEPS_CACHE_DIR}/gradle-${PORTNAME} \
${GRADLE_ARGS} --build-cache shadowJar