aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2022-05-15 22:35:14 +0000
committerJason Helfman <jgh@FreeBSD.org>2022-05-15 22:35:14 +0000
commit3958bab21d35ec7cac07bbbaabd1fd4fb90d2717 (patch)
tree5fd54bf57e929a1bfb23b6e2a6b1488009664484
parentaf4790a6153996202e85cba64aa9a222fcc62259 (diff)
downloadports-3958bab21d35ec7cac07bbbaabd1fd4fb90d2717.tar.gz
ports-3958bab21d35ec7cac07bbbaabd1fd4fb90d2717.zip
devel/py-fastf1: Add new port
FastF1 is a Python package for accessing and analyzing Formula 1 results, schedules, timing data and telemetry. WWW: https://github.com/theOehrly/Fast-F1
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-fastf1/Makefile27
-rw-r--r--devel/py-fastf1/distinfo3
-rw-r--r--devel/py-fastf1/pkg-descr4
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index beb4f8c13e23..280a659de90f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4521,6 +4521,7 @@
SUBDIR += py-fastcache
SUBDIR += py-fasteners
SUBDIR += py-fastentrypoints
+ SUBDIR += py-fastf1
SUBDIR += py-fastimport
SUBDIR += py-fastjsonschema
SUBDIR += py-fastnumbers
diff --git a/devel/py-fastf1/Makefile b/devel/py-fastf1/Makefile
new file mode 100644
index 000000000000..bb7f55bc231b
--- /dev/null
+++ b/devel/py-fastf1/Makefile
@@ -0,0 +1,27 @@
+# Created by: Jason Helfman <jgh@FreeBSD.org>
+
+PORTNAME= fastf1
+PORTVERSION= 2.2.5
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jgh@FreeBSD.org
+COMMENT= Python module to accessing and analyzing Formula 1 data
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}thefuzz>=0:devel/py-thefuzz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests-cache>=0:www/py-requests-cache@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}timple>=0:math/py-timple@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}signalr-client-aio>=0:devel/py-signalr-client-aio@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-fastf1/distinfo b/devel/py-fastf1/distinfo
new file mode 100644
index 000000000000..132d89316ee3
--- /dev/null
+++ b/devel/py-fastf1/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1652513072
+SHA256 (fastf1-2.2.5.tar.gz) = 89a1f8877ebfc3589196df928e961052829478d79ec5ee729d3320f7336de538
+SIZE (fastf1-2.2.5.tar.gz) = 73185
diff --git a/devel/py-fastf1/pkg-descr b/devel/py-fastf1/pkg-descr
new file mode 100644
index 000000000000..127935517e42
--- /dev/null
+++ b/devel/py-fastf1/pkg-descr
@@ -0,0 +1,4 @@
+FastF1 is a Python package for accessing and analyzing Formula 1 results,
+schedules, timing data and telemetry.
+
+WWW: https://github.com/theOehrly/Fast-F1