aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2022-10-24 17:38:37 +0000
committerThierry Thomas <thierry@FreeBSD.org>2022-10-26 17:58:26 +0000
commit3a06165f14666b9a5e1eca2e292fe96a895dcbd2 (patch)
tree651d6a3676c6cc03a23cc798340737bf2a5aa3e9
parentfb5d8423ae1d43ff5012df1e37ba8b8c843a69fe (diff)
downloadports-3a06165f14666b9a5e1eca2e292fe96a895dcbd2.tar.gz
ports-3a06165f14666b9a5e1eca2e292fe96a895dcbd2.zip
science/helfem: chase libXC 6.0.0
-rw-r--r--science/helfem/Makefile2
-rw-r--r--science/helfem/files/patch-src_general_dftfuncs.cpp38
2 files changed, 39 insertions, 1 deletions
diff --git a/science/helfem/Makefile b/science/helfem/Makefile
index 6f9725df90f2..ab460cd4002f 100644
--- a/science/helfem/Makefile
+++ b/science/helfem/Makefile
@@ -1,6 +1,6 @@
PORTNAME= helfem
DISTVERSION= g20210912
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= science # chemistry
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
diff --git a/science/helfem/files/patch-src_general_dftfuncs.cpp b/science/helfem/files/patch-src_general_dftfuncs.cpp
new file mode 100644
index 000000000000..999399167b70
--- /dev/null
+++ b/science/helfem/files/patch-src_general_dftfuncs.cpp
@@ -0,0 +1,38 @@
+--- src/general/dftfuncs.cpp.orig 2021-09-12 09:32:14 UTC
++++ src/general/dftfuncs.cpp
+@@ -388,7 +388,7 @@ double exact_exchange(int func_id) {
+ throw std::runtime_error(oss.str());
+ }
+
+-#if XC_MAJOR_VERSION < 6
++#if XC_MAJOR_VERSION < 7
+ switch(func.info->family)
+ {
+ #ifdef XC_FAMILY_HYB_LDA
+@@ -431,7 +431,7 @@ bool is_supported(int func_id) {
+ throw std::runtime_error(oss.str());
+ }
+ // Get flag
+-#if XC_MAJOR_VERSION >= 6
++#if XC_MAJOR_VERSION > 6
+ switch(xc_hyb_type(&func)) {
+ case(XC_HYB_SEMILOCAL):
+ case(XC_HYB_HYBRID):
+@@ -463,7 +463,7 @@ void is_range_separated(int func_id, bool & erf, bool
+ throw std::runtime_error(oss.str());
+ }
+ // Get flag
+-#if XC_MAJOR_VERSION < 6
++#if XC_MAJOR_VERSION < 7
+ erf=(func.info->flags & XC_FLAGS_HYB_CAM) || (func.info->flags & XC_FLAGS_HYB_LC);
+ yukawa=(func.info->flags & XC_FLAGS_HYB_CAMY) || (func.info->flags & XC_FLAGS_HYB_LCY);
+ #else
+@@ -507,7 +507,7 @@ void range_separation(int func_id, double & omega, dou
+ throw std::runtime_error(oss.str());
+ }
+
+-#if XC_MAJOR_VERSION >= 6
++#if XC_MAJOR_VERSION > 6
+ switch(xc_hyb_type(&func)) {
+ case(XC_HYB_SEMILOCAL):
+ break;